How can I disable gnome keyring?

Post your general questions or comments about GhostBSD here!
Post Reply
dantes102
Posts: 2
Joined: Thu Jun 10, 2021 6:12 am

How can I disable gnome keyring?

Post by dantes102 »

Hello,
when I try to connect to an sshd host with an ssh pub key from xterm, it appears the pop up window of gnome keyring asking for a password.
I was looking for /etc/xdg/autostart/gnome-keyring-ssh.desktop to disable keyring requests but I didn't find the folder.
There is a way to disable the gnome keyring daemon?
nevets
Posts: 53
Joined: Tue Jun 23, 2020 3:54 am

Re: How can I disable gnome keyring?

Post by nevets »

You can stop processes using the MATE menu....
Applications -> System Tools -> MATE System Monitor -> Processes
Scroll down to gnome-keyring-daemon, right select menu and 'stop process'.
Steve
dantes102
Posts: 2
Joined: Thu Jun 10, 2021 6:12 am

Re: How can I disable gnome keyring?

Post by dantes102 »

Thank you.
I disabled the service on "Startup Application Preferences" (System -> Preferences -> Personal -> Startup Applications).
But after I find a file name "gnome-keyring-daemo.core" in the user folder and I find a process running this file.
Please see the screenshot :
Image

Do you know something about this?
nevets
Posts: 53
Joined: Tue Jun 23, 2020 3:54 am

Re: How can I disable gnome keyring?

Post by nevets »

I'd presume a resource (daemon or application) called the process at some time following the startup of MATE...
Startup applications are called as MATE starts... this doesn't stop programs from running at other times.
Post Reply