Failing to boot after install

Questions about the installation of FreeBSD
NevilleGoddard
Developer
Posts: 505
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 12 times

Re: Failing to boot after install

Post by NevilleGoddard » Thu Mar 19, 2020 7:49 pm

Welcome to GhostBSD by the way and sorry for the late reply!!

NevilleGoddard
Developer
Posts: 505
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 12 times

Re: Failing to boot after install

Post by NevilleGoddard » Thu Mar 19, 2020 8:05 pm

Looking at FreeBSD forums, someone with your card put this in

/boot/loader.conf and it worked for him

hw.syscons.disable=1

So run these commands

ee /boot/loader.conf

Then enter somewhere in the file

hw.syscons.disable=1

Then press esc and save


And see if that works. What happens when you do the above it stops some of the output when booting and it looks garbled but allows the OS access to your graphics card

Make sure you have the

drm-fbsd12-kmod package installed also that you have in your

/etc/rc.conf file, in the kld_list line


amdgpu so it should look like this


kld_list="amdgpu linux plusotherstuff"

jcpollman
Posts: 11
Joined: Sat Dec 07, 2019 11:17 am
Has thanked: 0
Been thanked: 0

Re: Failing to boot after install

Post by jcpollman » Fri Mar 20, 2020 7:53 am

I have tried them all, but it will only boot into a graphical environment with scfb

NevilleGoddard
Developer
Posts: 505
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 12 times

Re: Failing to boot after install

Post by NevilleGoddard » Fri Mar 20, 2020 12:21 pm

I have a Radeon card that worked by doing the following

Edit /boot/loader.conf and put in

hw.syscons.disable=1


Put in the kld_list line in rc.conf

amdgpu

Then reboot

jcpollman
Posts: 11
Joined: Sat Dec 07, 2019 11:17 am
Has thanked: 0
Been thanked: 0

Re: Failing to boot after install

Post by jcpollman » Fri Mar 20, 2020 5:02 pm

I have tried them all, only scfb will start a graphical environment with my amd computer. It is a bit ugly (1024x768) but useable for installing. When I reboot the boot loader looks at all the partitions and says nothing is bootable.
JC

NevilleGoddard
Developer
Posts: 505
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 12 times

Re: Failing to boot after install

Post by NevilleGoddard » Fri Mar 20, 2020 11:28 pm

Strange. Your card should be supported

NevilleGoddard
Developer
Posts: 505
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 12 times

Re: Failing to boot after install

Post by NevilleGoddard » Fri Mar 20, 2020 11:33 pm


NevilleGoddard
Developer
Posts: 505
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 12 times

Re: Failing to boot after install

Post by NevilleGoddard » Fri Mar 20, 2020 11:34 pm

Please show your

/etc/rc.conf file

cat /etc/rc.conf

jcpollman
Posts: 11
Joined: Sat Dec 07, 2019 11:17 am
Has thanked: 0
Been thanked: 0

Re: Failing to boot after install

Post by jcpollman » Mon Mar 23, 2020 7:59 am

I finally got Ghost installed, and working well, on another computer. I spent well over 2 months on this, and think I will give it a rest until the next current version of FreeBSD comes out - in the autumn from my understanding
JC

Post Reply