Viber Linux Binary

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
Patience
Posts: 1
Joined: Sun Feb 02, 2020 6:31 am
Has thanked: 0
Been thanked: 0

Viber Linux Binary

Post by Patience » Sun Feb 02, 2020 7:38 am

Dear Eric and all others involved,

First of all thank you! I love GhostBSD and it's a great experience, both with Mate and my preferred KDE5. In fact, I love it so much that I am considering switching my main OS from Linux to GhostBSD. Not just because of systemd, but because the BSD kernel deserves its place on the desktop. I would say I am a somewhat advanced user, but not a computer scientist.

However, I do need to get two free but non-FOSS Linux binaries to run for my workflow. One of them is WPS Office, since I do work with a lot of MS Office files and I need to display them correctly. Libre Office, as much as I love it, just doesn't do that well enough for my purposes. But I might open another thread on that later, now I want to focus on Viber.

Since I deal a lot with Eastern Europe, where it is used widely, I do need Viber, which is an Instant messaging and telephony application developped by Japanese company Rakuten. I need to get it running at least for written messages, sending and receiving pictures (which are being embedded in the conversation), and sending and receiving files. If voice and video calls don't work, that will be ok. I only use audio, and mostly on my phone through the Android version anyway.


So this is how far I got:

1. Installed linux-c7 from Software Station

2. Went to viber.com and downloaded "Viber for Linux Fedora" .rpm file (only available as 64-bit; alternatil would be .deb "for Linux Ubuntu")

3. Installed viber.rpm contents into /compat/linux/

4. Attempted to launch /compat/linux/opt/viber/Viber
Error message:
/compat/linux/opt/viber/Viber: error while loading shared libraries: libxslt.so.1: cannot open shared object file: No such file or directory

5. Got CentOS 7 package libxslt-1.1.28-5.el7.x86_64.rpm and installed contents into /compat/linux/

6. Attempted to launch /compat/linux/opt/viber/Viber
Error message:
/compat/linux/opt/viber/Viber: error while loading shared libraries: libgsm.so.1: cannot open shared object file: No such file or directory

7. Got CentOS 7 package gsm-1.0.13-11.el7.x86_64.rpm and installed contents into /compat/linux/

8. Attempted to launch /compat/linux/opt/viber/Viber
Error message:
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /compat/linux/opt/viber/Viber)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /compat/linux/opt/viber/Viber)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /compat/linux/opt/viber/Viber)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5Sql.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5Multimedia.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /compat/linux/opt/viber/lib/libQt5Multimedia.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5WebSockets.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5WebEngine.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5DBus.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /compat/linux/opt/viber/lib/libViberRTC.so)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /compat/linux/opt/viber/lib/libViberRTC.so)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /compat/linux/opt/viber/lib/libicui18n.so.55)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /compat/linux/opt/viber/lib/libicuuc.so.55)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5Quick.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5Qml.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /compat/linux/opt/viber/lib/libQt5Qml.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5Network.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5Widgets.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5Gui.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5Core.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /compat/linux/opt/viber/lib/libQt5Core.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /compat/linux/opt/viber/lib/libQt5Core.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5WebEngineCore.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /compat/linux/opt/viber/lib/libQt5WebEngineCore.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /compat/linux/opt/viber/lib/libQt5WebEngineCore.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5WebChannel.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /compat/linux/opt/viber/lib/libQt5Positioning.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /compat/linux/opt/viber/lib/libQt5Positioning.so.5)
/compat/linux/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /compat/linux/opt/viber/lib/libQt5Positioning.so.5)


My understanding is that the issue is the Linux compatibility layer using an old glibc version. Is this correct? If so, is there a way to install the newer one? I was considering trying one from CentOS 8, but since I cannot exclude that doing that would break the whole Linux compatibility layer, I prefer to ask first. Thank you in advance for any help!

Post Reply