After Install it always shows the EFI Partition on Desktop

Post your general questions or comments about GhostBSD here!
Post Reply
Vermilion
Posts: 39
Joined: Sat Jan 18, 2020 5:52 am
Has thanked: 2 times
Been thanked: 5 times

After Install it always shows the EFI Partition on Desktop

Post by Vermilion »

Hello,

again a small question, how do I prevent the EFI Partition showing up on Desktop / in Caja?

User avatar
ericbsd
Developer
Posts: 1540
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 50 times
Been thanked: 80 times

Re: After Install it always shows the EFI Partition on Desktop

Post by ericbsd »

I have not found a fix for that problem yet, I am not sure what cause that but I know ti si related to the old Gnome mount and Caja, I hope to replace Gnome mount in the future with automount.

Vermilion
Posts: 39
Joined: Sat Jan 18, 2020 5:52 am
Has thanked: 2 times
Been thanked: 5 times

Re: After Install it always shows the EFI Partition on Desktop

Post by Vermilion »

I just looked If I can delete the files within, it works without any problem. So may be dangerous for beginner users! The files did not show up in my trash! But they are still in the hidden folder ".trash-1003" of the EFI Partition so I saved my system from not booting any more, moving the files back. :mrgreen:

I will also look for a solution to hide that partition.

Vermilion
Posts: 39
Joined: Sat Jan 18, 2020 5:52 am
Has thanked: 2 times
Been thanked: 5 times

Re: After Install it always shows the EFI Partition on Desktop

Post by Vermilion »

I tried this one:
https://unix.stackexchange.com/question ... ger/423468

changed the ada0p2 to ada0p1 but it did not work for me. Possible that MATE does not use HAL?

User avatar
ericbsd
Developer
Posts: 1540
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 50 times
Been thanked: 80 times

Re: After Install it always shows the EFI Partition on Desktop

Post by ericbsd »

It uses hal and consolekit2.

Vermilion
Posts: 39
Joined: Sat Jan 18, 2020 5:52 am
Has thanked: 2 times
Been thanked: 5 times

Re: After Install it always shows the EFI Partition on Desktop

Post by Vermilion »

I managed out to disable it by simple way!! :D

Just added this to my fstab:

Code: Select all

/dev/ada0p1 		none 		vfat    sw	0	0

Post Reply