failed checksum from repository

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
gbar
Posts: 24
Joined: Wed Apr 05, 2017 12:30 pm
Has thanked: 0
Been thanked: 0

failed checksum from repository

Post by gbar » Tue Jan 07, 2020 1:57 pm

hi folks,

trying to add gcc and python3 to my install and its saying for example :-

pkg: gcc-9_4 failed checksum from repository

Following a FreeBSD page i've tried
pkg check -s -a

this came up with loads of mismatches.

tried pkg check -r -a
Updating GhostBSD_PKG repository catalogue...
GhostBSD_PKG repository is up to date.
All repositories are up to date.
The following 5 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
gcc: 9_4
gcc9: 9.2.0
mpfr: 4.0.2
mpc: 1.1.0_2
binutils: 2.32_1,1

Number of packages to be installed: 5

but then came up with :-
pkg: gcc-9_4 failed checksum from repository

Any ideas?
thanks in advance

User avatar
ericbsd
Developer
Posts: 1461
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 40 times
Been thanked: 59 times

Re: failed checksum from repository

Post by ericbsd » Tue Jan 07, 2020 2:42 pm

That is weird I am not able to reproduce that on the main package repository.

can't you get me the output of cat /usr/local/etc/pkg/repos/GhostBSD.conf

gbar
Posts: 24
Joined: Wed Apr 05, 2017 12:30 pm
Has thanked: 0
Been thanked: 0

Re: failed checksum from repository

Post by gbar » Tue Jan 07, 2020 3:30 pm

Sure,

# $FreeBSD$
#
# To disable this repository, instead of modifying or removing this file,
# create a /usr/local/etc/pkg/repos/TrueOS.conf file:
#
# mkdir -p /usr/local/etc/pkg/repos
# echo "TrueOS: { enabled: no }" > /usr/local/etc/pkg/repos/TrueOS.conf
#

GhostBSD_PKG: {
url: "http://pkg.ghostbsd.org/stable/FreeBSD:12:amd64/latest",
enabled: yes
}
Thanks the above shows a previous install of TrueOS/Trident

User avatar
ericbsd
Developer
Posts: 1461
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 40 times
Been thanked: 59 times

Re: failed checksum from repository

Post by ericbsd » Wed Jan 08, 2020 8:21 am

Thanks, look like the Canadian servers the not sync properly last time.

I am trying to sync it back to se if it will solve the problem.

User avatar
ericbsd
Developer
Posts: 1461
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 40 times
Been thanked: 59 times

Re: failed checksum from repository

Post by ericbsd » Wed Jan 08, 2020 8:47 am

Look like the new sync fixed the problem let me know if it is still happening.

gbar
Posts: 24
Joined: Wed Apr 05, 2017 12:30 pm
Has thanked: 0
Been thanked: 0

Re: failed checksum from repository

Post by gbar » Wed Jan 08, 2020 9:00 am

Hi Eric,

tested and all good, thanks for the help
gbar

Post Reply