Can not mount Toshiba external HD [half solved]

Share your ideas, questions or suggestions with us here.
User avatar
slughorn
Posts: 58
Joined: Mon Oct 02, 2017 2:55 pm
Location: Grimma / Germany
Has thanked: 7 times
Been thanked: 2 times

Can not mount Toshiba external HD [half solved]

Post by slughorn » Sun Dec 01, 2019 5:59 am

I trayed

Code: Select all

sudo mount /dev/sdb /media/usb
t
o mount a Toshiba external HD 1 TB (my backups).
But I got the answer:

Code: Select all

No such file or directory
A stick with 16 GB works this way.
Last edited by slughorn on Mon Dec 09, 2019 12:50 pm, edited 1 time in total.

hunghung
Posts: 64
Joined: Tue Sep 24, 2019 1:31 pm
Has thanked: 2 times
Been thanked: 4 times

Re: Can not mount Toshiba external HD

Post by hunghung » Tue Dec 03, 2019 5:22 am

slughorn wrote:
Sun Dec 01, 2019 5:59 am
I trayed

Code: Select all

sudo mount /dev/sdb /media/usb
t
o mount a Toshiba external HD 1 TB (my backups).
But I got the answer:

Code: Select all

No such file or directory
A stick with 16 GB works this way.
Please note that GhostBSD (FreeBSD) is not Linux. sdX is a Linux disk name. On FreeBSD, if you only have one usb attached I guest it will likely to be /dev/da0.

p/s: Almost forgot, your command will also fail on Linux, as sdb is a whole disk, not the partition itself. If you want to mount the first partition, it will be sdb1 on Linux and da0s1 on FreeBSD. You could check it with gpart. You also have to make sure that the mount point /media/usb exists, I think you would better just mount it to /mnt.
Last edited by hunghung on Tue Dec 03, 2019 5:31 am, edited 2 times in total.

hunghung
Posts: 64
Joined: Tue Sep 24, 2019 1:31 pm
Has thanked: 2 times
Been thanked: 4 times

Re: Can not mount Toshiba external HD

Post by hunghung » Tue Dec 03, 2019 5:27 am

But exactly what is the file system used on your external HD?

NTFS? FAT32? ExFAT? Ext4?

Each will has a very different answer. BSD's mount utility is not as sophisticated as the Linux version, you have to specify the file system type yourself.

For example, if it's FAT32:

Code: Select all

sudo mount -v -t msdosfs /dev/da0s1 /mnt/

hunghung
Posts: 64
Joined: Tue Sep 24, 2019 1:31 pm
Has thanked: 2 times
Been thanked: 4 times

Re: Can not mount Toshiba external HD

Post by hunghung » Tue Dec 03, 2019 7:46 am


User avatar
slughorn
Posts: 58
Joined: Mon Oct 02, 2017 2:55 pm
Location: Grimma / Germany
Has thanked: 7 times
Been thanked: 2 times

Re: Can not mount Toshiba external HD

Post by slughorn » Wed Dec 04, 2019 9:28 am

I checked: It is ntfs.
The package

Code: Select all

ntfs-3g 
is installed.
I tried and got

Code: Select all

Cannot mount volume.

Code: Select all

Unable to mount the volume 'TOSHIBA EXT'.
I can see TOSHIBA EXT in the datei manager, but cannot open it.

dmesg shows:

Code: Select all

da4 at umass-sim1 bus 1 scbus9 target 0 lun 0
da4: <TOSHIBA External USB 3.0 5438> Fixed Direct Access SPC-4 SCSI device
da4: Serial Number 20141127025234
da4: 40.000MB/s transfers
da4: 953869MB (1953525164 512 byte sectors)
da4: quirks=0x2<NO_6_BYTE>

Code: Select all

# ntfs-3g /dev/da4 /mnt/TOSHIBA
NTFS signature is missing.
Failed to mount '/dev/da4': Invalid argument
The device '/dev/da4' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
Haw can I get further?

hunghung
Posts: 64
Joined: Tue Sep 24, 2019 1:31 pm
Has thanked: 2 times
Been thanked: 4 times

Re: Can not mount Toshiba external HD

Post by hunghung » Wed Dec 04, 2019 1:07 pm

slughorn wrote:
Wed Dec 04, 2019 9:28 am
I checked: It is ntfs.
The package

Code: Select all

ntfs-3g 
is installed.
I tried and got

Code: Select all

Cannot mount volume.

Code: Select all

Unable to mount the volume 'TOSHIBA EXT'.
I can see TOSHIBA EXT in the datei manager, but cannot open it.

dmesg shows:

Code: Select all

da4 at umass-sim1 bus 1 scbus9 target 0 lun 0
da4: <TOSHIBA External USB 3.0 5438> Fixed Direct Access SPC-4 SCSI device
da4: Serial Number 20141127025234
da4: 40.000MB/s transfers
da4: 953869MB (1953525164 512 byte sectors)
da4: quirks=0x2<NO_6_BYTE>

Code: Select all

# ntfs-3g /dev/da4 /mnt/TOSHIBA
NTFS signature is missing.
Failed to mount '/dev/da4': Invalid argument
The device '/dev/da4' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
Haw can I get further?
No, man. da4 is the disk itself. How many partitions did your disk have? If it's the first partition, it is da4s1, the second partition, da4s2, and so on.

Ian_Robinson
Posts: 4
Joined: Sat Dec 07, 2019 9:53 am
Has thanked: 0
Been thanked: 1 time

Re: Can not mount Toshiba external HD

Post by Ian_Robinson » Sat Dec 07, 2019 10:45 am

1. Following up on the post immediately above, you need to identify which "slice" of the disk to mount. While dmesg will identify the "whole" disk (i.e. da0, da1, etc.), you need to identify the "slice" (subdivision) of the disk as well. To do this,
you use this command in a terminal window:

gpart show

=> 40 1172123488 da0 GPT (559G)
40 512 1 freebsd-boot (256K)
2048 1166876672 2 freebsd-zfs (556G)
1166877224 5234688 3 freebsd-swap (2.5G)
1172111912 11616 - free -- (5.7M)

1 30605311 da1 MBR (15G)
31 - free - (16K)
30605280 1 ntfs (15G) <========== This slice (/dev/da1s1) is what you want to mount

The output under the top entry in each disk report shows that this computer has a hard disk (da0) formatted zfs, with three "slices" da0s1, da0s2, and da0s3. It also shows a USB stick (da1) formatted with slice "1" as ntfs. The full id of the USB NTFS slice is da1s1.

So . . . to mount the NTFS slice to the OS directory /mnt, you would use the command:

sudo ntfs-3g /dev/da1s1 /mnt

Where: /dev/da1s1 is the source NTFS slice, and
/mnt is the target directory where the contents of the drive will be mounted.

(NOTE: Sometimes, you will need to use a "p" instead of an "s", as in "da1p1" and you can use the command "gpart list" to determine whether to use "s" or "p")

2. To mount a FAT32 disk . . . sudo mount_msdosfs /dev/da1s1 /mnt

3. To UN-MOUNT the disk when finished, use the command: sudo umount /mnt (note the spelling. It is umount, not unmount)

4. Instead of gpart show command, you can also use the command ls /dev/da* to list all "da" disks
These users thanked the author Ian_Robinson for the post:
slughorn (Mon Dec 09, 2019 3:10 am)
Rating: 50%

User avatar
slughorn
Posts: 58
Joined: Mon Oct 02, 2017 2:55 pm
Location: Grimma / Germany
Has thanked: 7 times
Been thanked: 2 times

Re: Can not mount Toshiba external HD

Post by slughorn » Sun Dec 08, 2019 6:25 am

Now I get

gpart show
=> 40 976773088 ada0 GPT (466G)
40 512 1 freebsd-boot (256K)
552 971528192 2 freebsd-zfs (463G)
971528744 5234688 3 freebsd-swap (2.5G)
976763432 9696 - free - (4.7M)

=> 63 1953525101 da4 MBR (932G)
63 206785 - free - (101M)
206848 1953315840 1 ntfs [active] (931G)
1953522688 2476 - free - (1.2M)

=> 63 1953525101 diskid/DISK-20141127025234 MBR (932G)
63 206785 - free - (101M)
206848 1953315840 1 ntfs [active] (931G)
1953522688 2476 - free - (1.2M)

With
root@wolfgang:/usr/home/wolfgang # ntfs-3g /dev/da4s1 /mnt
root@wolfgang:/usr/home/wolfgang #
seems to work, but if I check I get the same result:
the file manager shows the external drive but tells me:
Can not mount volume.
Unable to mount the volume 'TOSHIBA EXT'.
Details:
mount: illegal option -m usage: mount[-t fstype] [-o options] target_fs mount_point

User avatar
slughorn
Posts: 58
Joined: Mon Oct 02, 2017 2:55 pm
Location: Grimma / Germany
Has thanked: 7 times
Been thanked: 2 times

Re: Can not mount Toshiba external HD

Post by slughorn » Sun Dec 08, 2019 6:47 am

The strange think is: at the Terminal I have access to the external device.
With cd I can walk through the drive and open the files.
But with the installed file manager it does not work. This was the way I am used to up to now.

hunghung
Posts: 64
Joined: Tue Sep 24, 2019 1:31 pm
Has thanked: 2 times
Been thanked: 4 times

Re: Can not mount Toshiba external HD

Post by hunghung » Mon Dec 09, 2019 2:11 am

slughorn wrote:
Sun Dec 08, 2019 6:47 am
The strange think is: at the Terminal I have access to the external device.
With cd I can walk through the drive and open the files.
But with the installed file manager it does not work. This was the way I am used to up to now.
With me possible to mount the partition is already good. Don't expect the same seamlessness as on Linux ;)
These users thanked the author hunghung for the post:
slughorn (Mon Dec 09, 2019 3:08 am)
Rating: 50%

Post Reply