sshd not starting up on system boot  [SOLVED]

Post your general questions or comments about GhostBSD here!
Post Reply
gautamdas
Posts: 6
Joined: Sat Jul 06, 2019 4:53 pm
Has thanked: 2 times
Been thanked: 0

sshd not starting up on system boot

Post by gautamdas » Sat Jul 06, 2019 6:49 pm

rc.conf has
sshd_enable="YES"

sysrc -a shows sshd_enable is set to YES.

[gautam@ghost ~]$ sysrc -a
devfs_system_ruleset: devfsrules_common
hostname: ghost
ifconfig_re0: DHCP
keymap: us.iso
kldload_nvidia: nvidia-modeset nvidia
ntpd_enable: YES
ntpd_sync_on_start: YES
rc_debug: YES
root_rw_mount: NO
sendmail_enable: NONE
sendmail_msp_queue_enable: NO
sendmail_outbound_enable: NO
sendmail_submit_enable: NO
sshd_enable: YES
zfs_enable: YES


However sshd service is not starting up on system boot.

In utter desperation I have resorted to checking and staring it from a cron job...
This is pathetic.

Have set rc_debug ="YES" and am getting no help.

What am I missing?

User avatar
ericbsd
Developer
Posts: 1360
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 34 times
Been thanked: 41 times

Re: sshd not starting up on system boot  [SOLVED]

Post by ericbsd » Mon Jul 08, 2019 2:13 pm

We use OpenRC so service is started differently.

Code: Select all

sudo rc-update add sshd default
These users thanked the author ericbsd for the post:
gautamdas (Tue Jul 09, 2019 9:42 pm)
Rating: 50%

gautamdas
Posts: 6
Joined: Sat Jul 06, 2019 4:53 pm
Has thanked: 2 times
Been thanked: 0

Re: sshd not starting up on system boot

Post by gautamdas » Tue Jul 09, 2019 6:30 pm

Thanks. Much appreciated.

What is the best way to start smbd and nmbd at boot?

User avatar
ericbsd
Developer
Posts: 1360
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 34 times
Been thanked: 41 times

Re: sshd not starting up on system boot

Post by ericbsd » Wed Jul 10, 2019 10:45 am

Same command but with your service instead of sshd.

Post Reply