Firewall - IPFW - strange behavior !

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
mic5263
Posts: 1
Joined: Wed Nov 14, 2018 6:52 pm
Has thanked: 0
Been thanked: 0

Firewall - IPFW - strange behavior !

Post by mic5263 » Wed Nov 14, 2018 6:57 pm

I am new with GhostBSD 18.10.
I build an ipfw.rules-file that starts with "ipfw -q -f flush" and ends
with "$cmd 00999 deny log all from any to any".
But when i execute "ipfw list" there is something strange at the end of the output, because the last of the list is:
65535 allow ip from any to any

Where does it come from ? Tried to delete it, but "ipfw: rule 65535 not found".
So whats wrong ?

And an other question : How to start ipfw at boot time ?
firewall_enable="YES" is set in rc.conf.
What else do i have to do ?

And why does pam configured with nologin not work ?

Thanks for your help.

NevilleGoddard
Developer
Posts: 431
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 7 times
Been thanked: 4 times

Re: Firewall - IPFW - strange behavior !

Post by NevilleGoddard » Thu Nov 15, 2018 9:10 am

Hi and welcome!
Unfortunately I've never used a firewall so I can't help you there. Sorry.
GhostBSD 18.10 uses OpenRC for its init system so you have to start it a different way.
Open a terminal and as root run this command

rc-update add ipfw default

This should start the ipfw service at the next boot
If you want to start it immediately run this as root

service ipfw onestart

If you want to disable the ipfw service run

rc-update delete ipfw


Please have a look at this also:

https://cooltrainer.org/a-freebsd-deskt ... /#firewall

All the best

Post Reply