First GhostBSD dev release of with TrueOS base system.

News and Announcements related to GhostBSD
Post Reply
User avatar
ericbsd
Developer
Posts: 1229
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 13 times
Been thanked: 14 times

First GhostBSD dev release of with TrueOS base system.

Post by ericbsd » Wed Aug 01, 2018 3:52 pm


User avatar
slughorn
Posts: 35
Joined: Mon Oct 02, 2017 2:55 pm
Location: Grimma / Germany
Has thanked: 0
Been thanked: 1 time

Re: First GhostBSD dev release of with TrueOS base system.

Post by slughorn » Sun Aug 05, 2018 3:20 pm

Hello Eric,

I have downloaded ans installed this OS on VirtualBox. After rebooting I got this error message:
Error activating XKB configuration.
It can happen under various circumstances:
. a bug in libxklaver library
. a bug in X server (xkbcomp, xmodmap utilities)
. X server with incompatible libxkbfile implementation

X server version data
The X.Org Foundation
11804000

I can not perform the suggest commands because keyboard after installation is not German anymore although I choose it during installation.
I will try it later again.

Wolfgang

User avatar
slughorn
Posts: 35
Joined: Mon Oct 02, 2017 2:55 pm
Location: Grimma / Germany
Has thanked: 0
Been thanked: 1 time

Re: First GhostBSD dev release of with TrueOS base system.

Post by slughorn » Sun Aug 05, 2018 4:35 pm

Code: Select all

xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "base", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "base", "pc105", "us", "", ""

Code: Select all

# gsettings list-keys org.mate.peripherals-keyboard-xkb.kbd
layouts
model
options


User avatar
ericbsd
Developer
Posts: 1229
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 13 times
Been thanked: 14 times

Re: First GhostBSD dev release of with TrueOS base system.

Post by ericbsd » Sun Aug 05, 2018 9:22 pm

Yeah, we all get that error, but thanks to reporting that.

User avatar
Powerwagon77
Posts: 17
Joined: Sat Jul 07, 2018 2:14 pm
Has thanked: 3 times
Been thanked: 4 times

Re: First GhostBSD dev release of with TrueOS base system.

Post by Powerwagon77 » Sun Aug 05, 2018 11:56 pm

The release looks great! Everything works nicely, except for DHCP under Linux KVM. I hope I'm not being too picky. Once I run 'dhclient vtnet0' things work great, but the live image never seems to pull an IP automatically.

NevilleGoddard
Developer
Posts: 419
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 6 times
Been thanked: 4 times

Re: First GhostBSD dev release of with TrueOS base system.

Post by NevilleGoddard » Mon Aug 06, 2018 9:32 am

Hi.
I made the error message disappear by going to keyboard preference settings
then clicking the layouts tab and click add and added a new keyboard with my country language and layout.
i then clicked add.
I then chose this new keyboard over the old keyboard.
Then no more error message.
Hope it works for you.

User avatar
slughorn
Posts: 35
Joined: Mon Oct 02, 2017 2:55 pm
Location: Grimma / Germany
Has thanked: 0
Been thanked: 1 time

Re: First GhostBSD dev release of with TrueOS base system.

Post by slughorn » Wed Aug 08, 2018 3:47 am

In keyboard setting is the correct country but my keyboard is a Logitech K270. I can not choose this one. I have tried all offers but no luck.

User avatar
slughorn
Posts: 35
Joined: Mon Oct 02, 2017 2:55 pm
Location: Grimma / Germany
Has thanked: 0
Been thanked: 1 time

Re: First GhostBSD dev release of with TrueOS base system.

Post by slughorn » Fri Aug 10, 2018 3:01 pm

@ NevilleGoddard Thanks, I have solved it. At first I looked the wrong way, for the keyboard model and options.
Now I chose +Add.

NevilleGoddard
Developer
Posts: 419
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 6 times
Been thanked: 4 times

Re: First GhostBSD dev release of with TrueOS base system.

Post by NevilleGoddard » Sun Aug 12, 2018 7:00 am

No worries. Glad it's fixed

User avatar
Casper
Posts: 18
Joined: Sun Jun 24, 2018 6:59 pm
Location: Houston, Texas, USA
Has thanked: 12 times
Been thanked: 1 time

Re: First GhostBSD dev release of with TrueOS base system.

Post by Casper » Tue Aug 14, 2018 9:13 pm

Eric,

The live usb runs fine (minus wifi). I went ahead and installed the dev release on an ssd in the caddy of my T430, and after a successful install, the boot process hangs with the message "BTX halted". No progression after that message. F.Y.I. ...

Post Reply