Someone adjust my monitor settings

Post your general questions or comments about GhostBSD here!
Post Reply
gT
Posts: 2
Joined: Thu Nov 23, 2017 4:36 pm
Has thanked: 1 time
Been thanked: 0

Someone adjust my monitor settings

Post by gT » Thu Apr 05, 2018 3:01 pm

Hello,

my system is a i7-860 asrock board with a NVidia GTX 960, 2GB video board. my Monitor is a ASUS 4k monitor connected with DisplayPort.

With 4K the character onscreen are to small for my eyes, so I adjust the screen resolution 2560x1440.

BUT, every time after "someone" put my system/monitor to sleep mode and I woke up the system I have the old 3840x2160 mode.

Where can I disable the sleep mode, or better, who (which program) think it is a good idea to set the 4K mode for the monitor?

/gT/

NevilleGoddard
Developer
Posts: 393
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 3 times
Been thanked: 1 time

Re: Someone adjust my monitor settings

Post by NevilleGoddard » Fri Apr 06, 2018 9:02 am

Hi, gT
To set the resolution across reboots you have to create a file in /usr/local/etc/X11/xorg.conf.d/

The file should be called screen-resolution.conf

Place the following lines in it:

Section "Screen"
Identifier "Screen0"
Device "Card0"
SubSection "Display"
Modes "2560x1440"
EndSubSection
EndSection

Save the file and reboot and the screen should always be this resolution.

There may be better solution, but I'm not sure about this one.
If the on screen characters are too small you may fix the problem by keeping the native (3840x2160) resolution and increasing the font size. In xfce you go to settings > appearance > fonts
You should see default font with a number next to the font name
Click on the number and choose a higher number and all desktop and menu fonts will be larger and this should fix your problem.
If you're using MATE the procedure should be something similar.
4K monitor eh? Lucky you. :D
These users thanked the author NevilleGoddard for the post:
gT (Fri Apr 06, 2018 5:03 pm)
Rating: 100%

gT
Posts: 2
Joined: Thu Nov 23, 2017 4:36 pm
Has thanked: 1 time
Been thanked: 0

Re: Someone adjust my monitor settings

Post by gT » Fri Apr 06, 2018 5:30 pm

NevilleGoddard wrote:
Fri Apr 06, 2018 9:02 am
To set the resolution across reboots you have to create a file in /usr/local/etc/X11/xorg.conf.d/

...

Save the file and reboot and the screen should always be this resolution.
I already have this file. That is not the solution. After the screen saver or whatever send the monitor into the sleep modus I have the wrong screen resolution.
NevilleGoddard wrote:
Fri Apr 06, 2018 9:02 am
There may be better solution, but I'm not sure about this one.
If the on screen characters are too small you may fix the problem by keeping the native (3840x2160) resolution and increasing the font size. In xfce you go to settings > appearance > fonts
You should see default font with a number next to the font name
Click on the number and choose a higher number and all desktop and menu fonts will be larger and this should fix your problem.
If you're using MATE the procedure should be something similar.
4K monitor eh? Lucky you. :D
That was also not the solution, but in the fonts-tab there is also a field for the DPI-Value of the monitor. It was set to 96dpi (wrong) and is now 157dpi.
Now I could read the characters without magnifying glass and the window decorations also have the right size. Thank you!!

/gT/
and a second time: thank you!

NevilleGoddard
Developer
Posts: 393
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 3 times
Been thanked: 1 time

Re: Someone adjust my monitor settings

Post by NevilleGoddard » Sat Apr 07, 2018 12:54 am

I'm glad you fixed your screen.
But I don't know why your resolution keeps changing if you have the configuration file. It should stay at the desired resolution.

Post Reply