Slow network speeds on a fresh install of GhostBSD

Help with setting up network cards, including WiFi cards.
Post Reply
ash01
Posts: 5
Joined: Sun Feb 11, 2018 6:15 pm
Has thanked: 0
Been thanked: 0

Slow network speeds on a fresh install of GhostBSD

Post by ash01 » Sun Feb 11, 2018 7:32 pm

Installed GhostBSD 11.1 on my desktop and my network speeds are slow all around. Pkg updates and upgrades are downloading around 50-100kb/s, and web browsing is equally as slow. I'm using wired ethernet that usually gets around 50mb/s or more using any other OS. Any ideas? Let me know what info you need, here is my ifconfig to get started.

$ ifconfig

Code: Select all

alc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=c319a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC,VLAN_HWTSO,LINKSTATE>
	ether 4c:cc:6a:8b:52:f7
	hwaddr 4c:cc:6a:8b:52:f7
	inet 216.165.254.143 netmask 0xfffffe00 broadcast 216.165.255.255 
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet autoselect (1000baseT <full-duplex,master>)
	status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
	inet6 ::1 prefixlen 128 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2 
	inet 127.0.0.1 netmask 0xff000000 
	nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
	groups: lo

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: Slow network speeds on a fresh install of GhostBSD

Post by NevilleGoddard » Mon Feb 12, 2018 2:41 am

Were you getting those slow speeds in the live session or just after the install?
What's the ethernet chip by the way?

ash01
Posts: 5
Joined: Sun Feb 11, 2018 6:15 pm
Has thanked: 0
Been thanked: 0

Re: Slow network speeds on a fresh install of GhostBSD

Post by ash01 » Mon Feb 12, 2018 12:45 pm

My ethernet chip: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller.

I am getting slow speeds on the live session and after installing.

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: Slow network speeds on a fresh install of GhostBSD

Post by NevilleGoddard » Tue Feb 13, 2018 8:12 am

You could try the command

dhclient alc0

from the command line and see if that works. Also try a static ip address. Maybe

Also try FreeBSD 12 and see if that helps. It may be a driver problem.

The alc(4) page has a couple of loader tunables that may make a difference. This is the page https://www.freebsd.org/cgi/man.cgi?alc%284%29

These are the tunables:

Tunables can be set at the loader(8) prompt before booting the kernel or
stored in loader.conf(5).

hw.alc.msi_disable
This tunable disables MSI support on the Ethernet hardware. The
default value is 0.

hw.alc.msix_disable
This tunable disables MSI-X support on the Ethernet hardware.
The default value is 0.
Try these.

Good luck!

ash01
Posts: 5
Joined: Sun Feb 11, 2018 6:15 pm
Has thanked: 0
Been thanked: 0

Re: Slow network speeds on a fresh install of GhostBSD

Post by ash01 » Tue Feb 13, 2018 1:06 pm

Alright, I'll try those commands. Also going to load up FreeBSD and see if it happens there.

Will report back with the results. Thanks.

Update:

I tried out FreeBSD and did not experience any network issues. I was able to upgrade and install packages quickly. I came back to GhostBSD and the problem persists. I am not experienced enough with BSD to know what this means.

I also tried the dhclient command, as well as switched to static IP. Neither seem to help.

I played with the tunables in loader.conf and nothing changed. I also tried ifconfig options in rc.conf.

I'm not really sure what else to do at this point.

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: Slow network speeds on a fresh install of GhostBSD

Post by NevilleGoddard » Thu Feb 15, 2018 8:15 am

Can you post the contents of the /etc/rc.conf file?
It must be that your network is not being configured correctly under GhostBSD for some reason.
Also what version of FreeBSD did you try?

ash01
Posts: 5
Joined: Sun Feb 11, 2018 6:15 pm
Has thanked: 0
Been thanked: 0

Re: Slow network speeds on a fresh install of GhostBSD

Post by ash01 » Sun Feb 18, 2018 2:12 am

Here is my rc.conf on a fresh install. I removed any changes because they weren't fixing anything.

Code: Select all

# Power saver.
powerd_enable="YES"
powerd_flags="-a adp -b adp"

# DEVFS rules
devfs_system_ruleset="devfsrules_common"
devd_enable="YES"

# usbd_enable="YES"
dbus_enable="YES"
hald_enable="YES"
polkit_enable="YES"

moused_enable="YES"
# iscsid_enable="YES"

# Enable linux compatibility
linux_enable="YES"

# Load the following kernel modules
kld_list="geom_mirror geom_journal geom_eli linux fuse ext2fs cuse"

# Configs from installed packages
webcamd_enable="YES"
vboxguest_enable="YES"
vboxservice_enable="YES"
cupsd_enable="YES"
lpd_enable="NO"

slim_enable="YES"
ntpd_enable="YES"
ntpd_sync_on_start="YES"
keymap="us.iso"
hostname="ash.ghostbsd-pc.home"
slim_enable="YES"
ifconfig_alc0="DHCP"
I tried FreeBSD 11.1 and 12, and had normal network speeds on both. I also tried TrueOS and had the same slow network speeds as GhostBSD, if that helps.

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: Slow network speeds on a fresh install of GhostBSD

Post by NevilleGoddard » Sun Feb 18, 2018 9:00 am

Try adding right below the ifconfig_alc0="DHCP" line the following

ifconfig_alc0_ipv6="inet6 accept_rtadv"

This may make a difference, but I'm not sure

ash01
Posts: 5
Joined: Sun Feb 11, 2018 6:15 pm
Has thanked: 0
Been thanked: 0

Re: Slow network speeds on a fresh install of GhostBSD

Post by ash01 » Tue Feb 20, 2018 6:38 pm

I reinstalled 11.1 and the issue has resolved itself. Network speeds are normal without modifying any configs.

I think the issue was related to my router. I had to unplug it for something unrelated and I think it reset some settings and fixed the issue.

Thanks for the help.

User avatar
ericbsd
Developer
Posts: 1194
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 7 times
Been thanked: 5 times

Re: Slow network speeds on a fresh install of GhostBSD

Post by ericbsd » Thu Feb 22, 2018 10:58 am

Yeah, should have suggested that Anytime I router slowness that what I do.

Post Reply