packet_invalid - no space buffer?!

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
murderman
Posts: 4
Joined: Tue Oct 07, 2014 6:28 pm
Has thanked: 0
Been thanked: 0

packet_invalid - no space buffer?!

Post by murderman » Tue Oct 07, 2014 6:37 pm

Ok so this error keeps throwing my wireless down - send_packet:Invalid and no space buffer ..currently im posting this via my phone ..is there any solutions ? Its my first time on any bsd system so has you can see im following the wiki for wifi until this error hit me

User avatar
ericbsd
Developer
Posts: 1440
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 39 times
Been thanked: 55 times

Re: packet_invalid - no space buffer?!

Post by ericbsd » Thu Oct 09, 2014 5:28 pm

I can you use lan line that you can give me the info I need?

if can in terminal give me the output of:

Code: Select all

cat /etc/rc.conf

Code: Select all

ifconfig

murderman
Posts: 4
Joined: Tue Oct 07, 2014 6:28 pm
Has thanked: 0
Been thanked: 0

Re: packet_invalid - no space buffer?!

Post by murderman » Thu Oct 09, 2014 7:42 pm

Ok ill post the results once i get home tomorrow in the morning since that's where i have a land line and i'm currently visiting some relatives and sadly they don't have a land line - posting this via phone

murderman
Posts: 4
Joined: Tue Oct 07, 2014 6:28 pm
Has thanked: 0
Been thanked: 0

Re: packet_invalid - no space buffer?!

Post by murderman » Fri Oct 10, 2014 2:17 pm

Code: Select all

ifconfig -
iwn0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
	ether 40:25:c2:30:f5:84
	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
	media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng
	status: associated
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
	ether 14:da:e9:01:e9:8e
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet autoselect (none)
	status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
	inet6 ::1 prefixlen 128 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 
	inet 127.0.0.1 netmask 0xff000000 
	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
wlan0: flags=8c43<UP,BROADCAST,RUNNING,OACTIVE,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 40:25:c2:30:f5:84
	inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255 
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
	status: no carrier
	ssid BHN5627 channel 11 (2462 MHz 11g ht/20)
	country US authmode WPA1+WPA2/802.11i privacy ON deftxkey UNDEF
	txpower 13 bmiss 10 scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250
	roam:rssi 7 roam:rate 64 protmode CTS ampdulimit 8k -amsdutx amsdurx
	shortgi wme roaming MANUAL
and

Code: Select all

cat /etc/rc.conf - 
#
# See /etc/defaults/rc.conf to add more option.
# Do not configure /etc/defaults/rc.conf.
# Configure only this file.
#
# Power saver.
powerd_enable="YES"
powerd_flags="-a adp -b adp"
# DEVFS rules
devfs_system_ruleset="system"
# All Gnome need. 
cupsd_enable="YES"
gdm_enable="YES"
hald_enable="YES"
dbus_enable="YES"
linux_enable="YES"
# Virtual Box adition configuration
vboxguest_enable="YES"
vboxservice_enable="YES"

#Netork card configuration by Networkmgr
wlans_iwn0="wlan0"
ifconfig_wlan0="WPA DHCP"
ifconfig_re0="DHCP"
gdm_lang="en_US.UTF-8"
keymap="us.iso"
hostname="Blackbird-SR92"
OK done and also do note that i have a wi-max / intel my wifi device in my laptop so if you need info on those let me know what to type

User avatar
ericbsd
Developer
Posts: 1440
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 39 times
Been thanked: 55 times

Re: packet_invalid - no space buffer?!

Post by ericbsd » Fri Oct 10, 2014 5:26 pm

OK your Wifi is active but your inet is 0.0.0.0. do you have wifi were you are right now.

Code: Select all

wlan0: flags=8c43<UP,BROADCAST,RUNNING,OACTIVE,SIMPLEX,MULTICAST> metric 0 mtu 1500
   ether 40:25:c2:30:f5:84
   inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
   nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
   media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
   status: no carrier
   ssid BHN5627 channel 11 (2462 MHz 11g ht/20)
   country US authmode WPA1+WPA2/802.11i privacy ON deftxkey UNDEF
   txpower 13 bmiss 10 scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250
   roam:rssi 7 roam:rate 64 protmode CTS ampdulimit 8k -amsdutx amsdurx
   shortgi wme roaming MANUAL
I had the same problem on wep protection 3 month ago, do you have wifi were you are right now?

Do you see Wifi network doing this in terminal:

Code: Select all

ifconfig wlan0 up scan

murderman
Posts: 4
Joined: Tue Oct 07, 2014 6:28 pm
Has thanked: 0
Been thanked: 0

Re: packet_invalid - no space buffer?!

Post by murderman » Fri Oct 10, 2014 6:11 pm

Yea i have wifi right now and i see my network And can connect to it but sadly it's a provider network so i'd have to buy another one and chain it some how(to change wep) but the good thing is i do have a land line and it'll work for for now until i have a another wifi network

User avatar
ericbsd
Developer
Posts: 1440
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 39 times
Been thanked: 55 times

Re: packet_invalid - no space buffer?!

Post by ericbsd » Fri Oct 10, 2014 7:20 pm

Eh I might have trick for you.

If your router is set from default your router IP might be 192.168.0.1 which you can this:

Code: Select all

ifconfig wlan0 inet 192.168.0.14/24
When you are connected to your wifi.

Post Reply