GhostBSD-11 testing the "test" repository

Open development discussions

Moderator: Developer

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard » Thu Aug 03, 2017 5:04 am

Will do. Thanks ASX.

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard » Thu Aug 03, 2017 9:14 am

looks like it's working now. It got past gstreamer-pligins-soup. 8-)

Thanks again, ASX. I had a little glimpse of the new-look GhostBSD and it lookks great. Can't wait to install it on my laptop!

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard » Thu Aug 03, 2017 9:30 am

But I ran into this:

Creating ISO...
grub-mkrescue: warning: Your xorriso doesn't support `--grub2-boot-info'. Some features are disabled. Please use xorriso 1.2.9 or later..
Shared object "libreadline.so.6" not found, required by "xorriso"
md5: GhostBSD11.1-ALPHA-20170803-212829-xfce-amd64.iso: No such file or directory
*** Error code 1

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard » Thu Aug 03, 2017 9:36 am

I re-installed xorriso-1.4.6 and then I got:

#### Building bootable ISO image for amd64 ####
### ISO created ###
Creating ISO...
GNU xorriso 1.4.6 : RockRidge filesystem manipulator, libburnia project.

Drive current: -outdev 'stdio:/usr/obj/amd64/xfce/GhostBSD11.1-ALPHA-20170803-213354-xfce-amd64.iso'
Media current: stdio file, overwriteable
Media status : is blank
Media summary: 0 sessions, 0 data blocks, 0 data, 719g free
Added to ISO image: directory '/'='/tmp/grub.jisOan'
xorriso : UPDATE : 614 files added in 1 seconds
Added to ISO image: directory '/'='/usr/ghostbsd-fs/amd64/xfce'
xorriso : UPDATE : 3057 files added in 1 seconds
xorriso : WARNING : -volid text does not comply to ISO 9660 / ECMA 119 rules
xorriso : NOTE : Copying to System Area: 512 bytes from file '/usr/local/lib/grub/i386-pc/boot_hybrid.img'

UNIX-SIGNAL: SIGSEGV errno= 45
xorriso : ABORT : Trying to shut down drive and library
xorriso : ABORT : Wait the normal burning time before any kill -9

xorriso : ABORT : Program done. Even if you do not see a shell prompt.

md5: GhostBSD11.1-ALPHA-20170803-213354-xfce-amd64.iso: No such file or directory
*** Error code 1

Stop.
Any ideas?

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: GhostBSD-11 testing the "test" repository

Post by ASX » Thu Aug 03, 2017 10:21 am

NevilleGoddard wrote:I re-installed xorriso-1.4.6 and then I got:
...

Any ideas?
Yes, it is a known issue with xorriso.

disinstall grub2-efi from your system, and retry.

The generated ISO will not support UEFI but it will work for legacy boot.

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard » Thu Aug 03, 2017 10:25 am

That did the trick. Thanks again, ASX.
I don't need uefi anyway. :)

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard » Thu Aug 03, 2017 10:56 am

GhostBSD looks and works great! Thanks for all your work! The live system booted up very quickly and seemed very responsive.
The installer or the chat desktop items didn't have icons but I'm not complaining, as long as they work. The chat one seemed to do I suppose the installer will work fine. It's too late to do an install now. I will tomorrow.

I chose the Numix full-dark theme and opened up youtube and the text in the search box was invisible. This is a common problem with Firefox and xfce I think. My workaround in my current desktop was to put a "chrome" folder in .mozilla/firefox/xxxxxxxxx.default folder with this text file in it:

The text file is called "userContent.css" and it contains the following:

input:not(.urlbar-input):not(.textbox-input):not(.form-control):not([type='checkbox']) {
-moz-appearance: none !important;
background-color: white;
color: black;
}

#downloads-indicator-counter {
color: white;
}

textarea {
-moz-appearance: none !important;
background-color: white;
color: black;
}

select {
-moz-appearance: none !important;
background-color: white;
color: black;
}

and this solves the problem. 8-)

I tried to reboot but the reboot button was greyed out. I had to open a terminal and enter su and that got me to be a root user. I was then able to enter the reboot command.

Thanks a lot again, GhostBSD team!

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: GhostBSD-11 testing the "test" repository

Post by ASX » Thu Aug 03, 2017 11:18 am

currently the xfce has another small issue: the selected keyboard is not retained.
We have already fixed that, but the fix will be available only upon completation of pkgs repos rebuild, which is in progress right now

Thanks for your accurate reports and solutions.

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard » Thu Aug 03, 2017 11:42 am

Can't wait to install it tomorrow.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: GhostBSD-11 testing the "test" repository

Post by ASX » Thu Aug 03, 2017 11:51 am

NevilleGoddard wrote:Can't wait to install it tomorrow.
welcome aboard! :D :mrgreen:

Post Reply