GhostBSD-11 testing the "test" repository

Open development discussions

Moderator: Developer

NevilleGoddard
Developer
Posts: 394
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 3 times
Been thanked: 1 time

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard » Wed Aug 02, 2017 11:02 am

Sorry, ASX.
I was testing xfce GhostBSD-11-amd64 repo not GhostBSD11.1-amd64(?) test repo.

I have in GhostBSD.conf

GhostBSD: {
url: "http://pkg.GhostBSD.org/GhostBSD-11/amd64/test",
enabled: yes
}

and no FreeBSD repo

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: GhostBSD-11 testing the "test" repository

Post by ASX » Wed Aug 02, 2017 11:14 am

The repo name is correct, tn that

Code: Select all

url: "http://pkg.GhostBSD.org/GhostBSD-11/amd64/test"
refers exactly a 11.1

the ABI is the same for 11.0 and 11.1, therefore we used the shortest notation: GhostBSD-11

From this point of view, your configuration look correct.

I'm assuming you built the ISO yourself for GhostBSD 11.1 ... and there could be the problem:
my latest test are from yesterday, and "mate" appear to not start Xorg, while "xfce" seems to work, (it did for me at least).

Those things are under investigation right now ... I will post back as soon as there is some news.

NevilleGoddard
Developer
Posts: 394
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 3 times
Been thanked: 1 time

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard » Wed Aug 02, 2017 11:22 am

Actually no I didn't build it myself. I tried to build an ISO but it wouldn't fetch the files. It said no such repository or something. Sorry, I can't remember.
I upgraded from 11-alpha-1.

The crazy thing is that the /lib/libz.so.6 file is there.

I upgraded my desktop using the same method and everything went fine.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: GhostBSD-11 testing the "test" repository

Post by ASX » Wed Aug 02, 2017 11:26 am

Well, the error is not about a missing libz, is about an incorrect version of libz.

I'm updating my latest install right now ... it will take some time..

NevilleGoddard, if possible join us on Freenode #ghosbsd or #ghostbsd-dev IRC channels. ;)
(GhostBSD provide hexchat program, already set for that)

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: GhostBSD-11 testing the "test" repository

Post by ASX » Wed Aug 02, 2017 11:29 am

NevilleGoddard wrote:Actually no I didn't build it myself. I tried to build an ISO but it wouldn't fetch the files.
Please retry, it is working for me and I see no reason why it should not work for you.
Be sure to pull in the latest changes (git pull).

NevilleGoddard
Developer
Posts: 394
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 3 times
Been thanked: 1 time

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard » Wed Aug 02, 2017 11:36 am

Thanks ASX.
Last time tried I got:

#### Fetching world for amd64 architecture ####
fetch: ftp://ftp.freebsd.org/pub/FreeBSD/relea ... 3/base.txz: File unavailable (e.g., file not found, no access)
*** Error code 1

Will try again tomorrow after reinstalling ghostbsd-build. ;)

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: GhostBSD-11 testing the "test" repository

Post by ASX » Wed Aug 02, 2017 11:42 am

NevilleGoddard wrote:Thanks ASX.
Last time tried I got:

#### Fetching world for amd64 architecture ####
fetch: ftp://ftp.freebsd.org/pub/FreeBSD/relea ... 3/base.txz: File unavailable (e.g., file not found, no access)
*** Error code 1

Will try again tomorrow after reinstalling ghostbsd-build. ;)
Uh ... I see, it is still referring 11.1-RC3, guess that it worked for me because this file is cached on my system ... Thanks!
Will be fixed soon ;)

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: GhostBSD-11 testing the "test" repository

Post by ASX » Wed Aug 02, 2017 12:08 pm

Fixed! NevilleGoddard, please retry now. ;)

NevilleGoddard
Developer
Posts: 394
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 3 times
Been thanked: 1 time

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard » Thu Aug 03, 2017 1:48 am

I tried and unfortunately I got this:

Installing package gstreamer-plugins-soup
gstreamer-plugins-soup not found in repos
*** Error code 1

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: GhostBSD-11 testing the "test" repository

Post by ASX » Thu Aug 03, 2017 4:19 am

NevilleGoddard wrote:I tried and unfortunately I got this:

Installing package gstreamer-plugins-soup
gstreamer-plugins-soup not found in repos
*** Error code 1
Very strange .... the pkg is available: http://pkg.ghostbsd.org/GhostBSD-11/amd ... 0.36_6.txz
and I also built some ISOs after posting about the fix, so the build scripts are OK.

NevilleGoddard, try to delete the build cache:

Code: Select all

rm -rf /usr/ghostbsd-fs/cache
then restart the build

Post Reply