GhostBSD-11 testing the "test" repository

Open development discussions

Moderator: Developer

NevilleGoddard
Developer
Posts: 506
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 13 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard »

I think I may have fixed the PATH problem in lightdm. 8-)

Logging in with lightdm the network icon is normal now and ifconfig now returns normal output. :D

The way I fixed it was to copy some lines from the .profile file in the "file system" section I think it's called HOME/.profile.

My .profile has this:

# $FreeBSD: releng/11.0/etc/root/dot.profile 278616 2015-02-12 05:35:00Z cperciva $
#
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:~/bin
export PATH
HOME=/root
export HOME
TERM=${TERM:-xterm}
export TERM
PAGER=more
export PAGER

I copied these lines:

PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:~/bin
export PATH

into the .xprofile file in my home folder

my .xprofile now looks like this:

#!/bin/sh
setxkbmap -layout jp -variant OADG109A
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:~/bin
export PATH

the command echo $PATH under fish and lightdm now returns:

/sbin /bin /usr/sbin /usr/bin /usr/local/sbin /usr/local/bin /home/neville/bin

I hope this is a fix. I haven't found any adverse effects from this change.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 1 time

Re: GhostBSD-11 testing the "test" repository

Post by ASX »

/etc/profile and $HOME&.profile are initialization files evaluated from /bin/sh
other shell may use different files, i.e. bash use $HOME/.bashrc

I understand that your changes are working with your setup, but I'm not sure it is the proper fix.

To which package belong $HOME/.xprofile ?
(that's copied for each new user, probably from /etc/skel/ or /usr/local/etc/skel/ ....).

Eric told me that the PATH problem existed for fish only, and not for /bin/sh, your report seems to correlate it to lightdm, independently from the shell used ... something doesn't add up.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 1 time

Re: GhostBSD-11 testing the "test" repository

Post by ASX »

btw, the updated i386 repo now is online too. ;)

NevilleGoddard
Developer
Posts: 506
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 13 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard »

Just as I thought.

Not a fix but a hack.

But it works. :)

I think the xprofile file is a lightdm file.

At least lightdm uses it, according to Arch wiki

NevilleGoddard
Developer
Posts: 506
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 13 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard »

I think I'll do a FreeBSD install without fish and use lightdm and see what happens.

But it looks to me that fish is not the problem but lightdm.

I'll see if this "fix" works if there is a path problem.

NevilleGoddard
Developer
Posts: 506
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 13 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard »

I did an install of FreeBSD11 with no fish and lightdm

echo $PATH returns:

/usr/local/bin:/usr/bin:/bin

I'll try now with slim enabled

NevilleGoddard
Developer
Posts: 506
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 13 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard »

With SLiM and no fish same machine

echo $PATH returns:

/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin

It looks to me like lightdm configuration somewhere is the problem. Not fish.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 1 time

Re: GhostBSD-11 testing the "test" repository

Post by ASX »

NevilleGoddard wrote:I did an install of FreeBSD11 with no fish and lightdm

echo $PATH returns:

/usr/local/bin:/usr/bin:/bin

I'll try now with slim enabled
I see you are havinng fun! :mrgreen:

Please stop here, your output doesn't look correct!

The PATH here should already include /sbin and /usr/sbin ... as defined in /etc/login.conf

Code: Select all

default:\
        :passwd_format=sha512:\
        :copyright=/etc/COPYRIGHT:\
        :welcome=/etc/motd:\
        :setenv=MAIL=/var/mail/$,BLOCKSIZE=K:\
        :path=/sbin /bin /usr/sbin /usr/bin /usr/local/sbin /usr/local/bin ~/bin:\
        :nologin=/var/run/nologin:\
   ....

NevilleGoddard
Developer
Posts: 506
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 13 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard »

Yes, I am. :D

This is my login.conf :

default:\
:passwd_format=sha512:\
:copyright=/etc/COPYRIGHT:\
:welcome=/etc/motd:\
:setenv=MAIL=/var/mail/$,BLOCKSIZE=K:\
:path=/sbin /bin /usr/sbin /usr/bin /usr/local/sbin /usr/local/bin ~/bin:\
:nologin=/var/run/nologin:\
:cputime=unlimited:\

this is echo $PATH with SLiM:

/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin

Hang on while I reboot and enable lightdm :mrgreen:

NevilleGoddard
Developer
Posts: 506
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 13 times

Re: GhostBSD-11 testing the "test" repository

Post by NevilleGoddard »

This is echo $PATH under lightdm

:/usr/local/bin:/usr/bin:/bin

I don't know what to make of it.

Post Reply