Installation 11.1 and Latest - Dual Boot

Share your ideas, questions or suggestions with us here.
Post Reply
Posts: 13
Joined: Wed Aug 01, 2018 10:33 am
Has thanked: 2 times
Been thanked: 3 times

Installation 11.1 and Latest - Dual Boot

Post by jmp20 »

I have been a fan of FreeBSD on servers for years thus I tried to setup GhostBSD on my new laptop. But I had some problems installing GhostBSD. The installation process kept failing after creating partitions. My disk layout is p1 EFI, p2 windblows, p3,p4 debian, p5,p6 GhostBSD. Also, when installing and setting up the partitions, GhostBSD creates an EFI partition, p5, even when one already exists. I tried it with both version 11.1 and latest. I was trying the installation from a USB stick. During installation, the processes tried to copy and extract GhostBSD package files from the install USB onto partition ada0p2 no matter what the disk partition layout was. I found this error on the .pc install logs. On the logs, it clearly show the process formatting the partitions then trying to copy the packages onto ada0p2 then extract them. Since this was a new laptop install, I recreated the partition layout to have GhostBSD at beginning of the disk. This is my new disk layout:
p1 efi
p2 GhBSD
p3 GhBSD Swap
p4 Linux
p5 Linux
p6 wdos
After creating this layout GhostBSD installation worked well. I first installed GhBSD, then the other OSes. I am now joying GhostBSD and I hope this helps someone with the install quirts of GhBSD.
Last edited by jmp20 on Mon Aug 06, 2018 11:21 am, edited 2 times in total.

User avatar
Posts: 18
Joined: Sat Jul 07, 2018 2:14 pm
Has thanked: 3 times
Been thanked: 5 times

Re: Installation 11.1 and

Post by Powerwagon77 »

TL;DR I created a VM and used 'dd' to put it onto the partition of my choice. The installer doesn't work sometimes, and I'm not smart enough to figure out why. When using 'dd', just copy the partition, not the whole disk.

LONG version with directions: ... 1048#p5940

Post Reply