[solved] Firefox no sound

Add your Tips and tricks to configure and tweak your GhostBSD System here.
Post Reply
MonkeyP99
Posts: 1
Joined: Thu Jul 22, 2021 12:44 am

[solved] Firefox no sound

Post by MonkeyP99 »

For those having issues with sound in the Firefox browser. Follow the instructions below.

Try testing other browser and application to see if sound works...

Try switching the default device...

Code: Select all

root@ghostbsd-pc:/usr/home/ # sysctl hw.snd.default_unit=1

root@ghostbsd-pc:/usr/home/ # cat /dev/sndstat
Installed devices:
pcm0: <Conexant CX20585 (Right Analog)> (play/rec)
pcm1: <Conexant CX20585 (Internal Analog)> (play/rec) default
pcm2: <Intel Ibex Peak (HDMI/DP 8ch)> (play)
pcm3: <Intel Ibex Peak (HDMI/DP 8ch)> (play)
Test with other applications...

Test with Firefox, if not working, follow instructions below.

OK, now that other applications are working... next let's get Firefox working...

Get some info from the firefox package.

Code: Select all

f@ghostbsd-pc ~> pkg info -xD firefox

More reading:


## Audio backend

Currently used audio backend can be inspected on `about:support` page.
Supported backends and default probing order is as follows:
- `pulse-rust` if `pulseaudio` package is installed (PULSEAUDIO option)
- `jack` if `jackit` package is installed (JACK option)
- `sndio` if `sndio` package is installed (SNDIO option)
- `alsa` if `alsa-lib` package is installed (ALSA option)
- `oss` (always available)

To force a specific backend open `about:config` page and create
`media.cubeb.backend` preference.
In firefox, open a new tab, about:config

Create media.cubeb.backend as indicated above, set it to oss. Restart Firefox.
This worked for me.

Additionally, you can set it to sndio, but you will have to start the sndiod.

Code: Select all

f@ghostbsd-pc ~> sndiod
Here is my freebsd/ghostbsd versions.

Code: Select all

Name           : os-generic-userland
Version        : 21.06.23
Installed on   : Sun Jul 18 20:28:37 2021 PDT
Origin         : os/userland
Architecture   : FreeBSD:13:amd64
linunix
Posts: 16
Joined: Tue Apr 14, 2020 3:44 pm

Re: [solved] Firefox no sound

Post by linunix »

Thanks. Since I am using Chromium as my major browser, I didn't notice firefox has a sound problem.
But this article helped me. I set to 'sndio' and it works.(oss is also working but alsa not)
Post Reply