[Solved]enable autologin

Add your Tips and tricks to configure and tweak your GhostBSD System here.
Post Reply
christophe60_fr
Posts: 26
Joined: Thu Oct 29, 2015 3:05 pm
Has thanked: 0
Been thanked: 0

[Solved]enable autologin

Post by christophe60_fr » Thu Oct 20, 2016 5:51 am

Hi,

GhostBSD 10.3 XFCE 64-bit.

Is there a special way to enable autologin with Slim ?
It doesn't seem to work.

Thanks.
Last edited by christophe60_fr on Thu Oct 20, 2016 1:44 pm, edited 1 time in total.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: enable autologin

Post by ASX » Thu Oct 20, 2016 7:00 am

Yes, there is a way, a require two changes:
- edit /usr/local/etc/slim.conf: set default_user and autologin
- edit ~/.xinitrc:

the problem is .xinitrc actually contain "exec $1", where $1 is feed from slim depending on the desktop choosen using F1,
when autologin is anabled, slim doesn't feed that variable, and you need to set it explicitly, in example:
exec /usr/local/bin/startxfce4
or
exec /usr/local/bin/mate-session
depending on your desktop of choice.

christophe60_fr
Posts: 26
Joined: Thu Oct 29, 2015 3:05 pm
Has thanked: 0
Been thanked: 0

Re: enable autologin

Post by christophe60_fr » Thu Oct 20, 2016 1:41 pm

Great !
Thank you very much.

purebsd
Posts: 1
Joined: Sat Dec 10, 2016 11:04 pm
Has thanked: 0
Been thanked: 0

Re: [Solved]enable autologin

Post by purebsd » Sat Dec 10, 2016 11:47 pm

I had the same question. Thanks!

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: [Solved]enable autologin

Post by ASX » Sun Dec 11, 2016 8:57 am

purebsd wrote:I had the same question. Thanks!
Glad it worked for you too!

For completeness, the code below (~/.xinitrc) will work with and without autologin enabled:

Code: Select all

DEFAULT=startxfce4

[ -n "$1" ] && exec $1

exec ${DEFAULT}

thorjeus
Posts: 4
Joined: Sun Oct 27, 2019 7:37 am
Has thanked: 0
Been thanked: 0

Re: [Solved]enable autologin

Post by thorjeus » Fri Nov 01, 2019 12:36 am

Hi,
How to autologin on mate desktop?
Thank you.

hunghung
Posts: 54
Joined: Tue Sep 24, 2019 1:31 pm
Has thanked: 2 times
Been thanked: 1 time

Re: [Solved]enable autologin

Post by hunghung » Wed Nov 06, 2019 3:02 am

thorjeus wrote:
Fri Nov 01, 2019 12:36 am
Hi,
How to autologin on mate desktop?
Thank you.
Wondered the same thing. On MX Linux, I always set to Autologin by default :)

Post Reply