Testing 11.1-BETA1

Testing New Feature in development.

Moderator: Developer

Post Reply
kraileth
Posts: 312
Joined: Sun Sep 04, 2016 12:30 pm
Has thanked: 0
Been thanked: 0

Testing 11.1-BETA1

Post by kraileth » Mon Sep 25, 2017 8:36 am

Took the chance at the weekend to do a little testing: I backed up data and did test installations of GhostBSD on several machines. Almost everything worked well. Here's just two things that I encountered for now:

1. On one machine with Intel graphics SLiM (well, actually X11) wouldn't start. I logged in as root, did a kldload i915kms ; slim and all was set.

Eric: What has happened to that dialog-based (?) configuration menu of 11.0-ALPHA? Do you intend to bring that back? If not: Do you think adding i915kms to kld_list in rc.conf would be a problem on some other systems? Either way: Currently users with similar hardware will not be able to use 11.1-BETA1 if they don't know a bit about all that fuss with recent versions of X on FreeBSD.

2. The update-station seems to be broken. In the past I often had the case where I'd have to pkg update manually and then it would display that it had updates available. Now I could not even get it to work at all on 11.1-BETA1. In fact not even the icon appears in the panel. Am I doing something wrong or is this a known problem?

User avatar
ericbsd
Developer
Posts: 1289
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 17 times
Been thanked: 24 times

Re: Testing 11.1-BETA1

Post by ericbsd » Mon Sep 25, 2017 9:30 am

The update manager should only appear if there is an update.

i968 driver could be load by default without a problem.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: Testing 11.1-BETA1

Post by ASX » Mon Sep 25, 2017 10:02 am

kraileth wrote:Do you think adding i915kms to kld_list in rc.conf would be a problem on some other systems? Either way: Currently users with similar hardware will not be able to use 11.1-BETA1 if they don't know a bit about all that fuss with recent versions of X on FreeBSD.
I'm with kraileth on this i915kms issue: it appears that after some Xorg update (back in Februrary&March or so), some (and not all) intel graphics is not recognized like it was previously.

Unless the issue is already solved by a subsequent update, it is worth some consideration.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: Testing 11.1-BETA1

Post by ASX » Mon Sep 25, 2017 10:09 am

At very least, I would mention that on some release notes, so that eventually the user can fix it quickly! ;)

Post Reply