update - confused?

Everything related to Installing and maintaining software with pkg(pkgng).
Post Reply
mechanic
Posts: 12
Joined: Sun Dec 13, 2015 12:54 pm
Has thanked: 0
Been thanked: 0

update - confused?

Post by mechanic »

New installation in virtualBox of ghostBSD 10.1 RELEASE. According to the G-BSD FAQ and the FreeBSD handbook I run '# freebsd-update fetch', and I get a list of over 1000 items to be re-installed or updated. This seems a lot for a new install! Then I run 'freebsd-update install' and immediately see a list of missing files and then the command terminates. So this is not a good thing.
What is the current preferred update method? This is between releases, and looking for e.g. security patches.
Thanks for any help.

User avatar
ericbsd
Developer
Posts: 1525
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 47 times
Been thanked: 78 times

Re: update - confused?

Post by ericbsd »

I will like to know if it is i386 or amd64.

mechanic
Posts: 12
Joined: Sun Dec 13, 2015 12:54 pm
Has thanked: 0
Been thanked: 0

Re: update - confused?

Post by mechanic »

ericbsd wrote:I will like to know if it is i386 or amd64.
Thanks for the response, it's a 64bit system.

User avatar
ericbsd
Developer
Posts: 1525
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 47 times
Been thanked: 78 times

Re: update - confused?

Post by ericbsd »

If you have seen lines similar to:

Code: Select all

install: ///usr/src/ No such file or directory
you it is because the source code of FreeBSD is not install and you should be up to date. Anything under /usr/src is not install.

You need to look at if you your ate the latest version.

Code: Select all

freebsd-version
10.1-RELEASE-p25
If you are at p25 you are up to date.

mechanic
Posts: 12
Joined: Sun Dec 13, 2015 12:54 pm
Has thanked: 0
Been thanked: 0

Re: update - confused?

Post by mechanic »

So why doesn't freebsd-update tell me this?

Post Reply