Page 1 of 1

Failed Update, now can't install at all

Posted: Sun May 24, 2020 10:38 am
by chemikalguy
I am new to the *nix world, so be gentle. I have a 1-month old GhostBSD installation, and this morning I saw the notification in the top bar that I had updates, so I clicked it and told the system to update. I then got a notice that there was an error, and to check the log. When I clicked the button to look, nothing happened, so I had to click 'cancel'.

I manually tried to launch the update station, but it never launched, so I rebooted. I tried again after the reboot, and it launched, but it hung during the scanning phase at about 10%. I ran the 'sudo pkg update -f' command, and this was the output:
updating ghostbsd repository catalogue....

(after about 5 minutes) it timed out and said:

repository GhostBSD has no meta file, using default settings. It hung there until I killed it after about ten minutes.

I rebooted again, and launched the software station, and it loaded, but never scanned for software. In the bottom of the tray it says 'packages available 0', and everything is blank. Is there a process or service or something that's hung somewhere? I don't know enough about logs to know which log to look in for errors.



Re: Failed Update, now can't install at all

Posted: Mon May 25, 2020 8:42 am
by chemikalguy
I was able to resolve this simply enough. It turns out that my pfsense firewall was blocking the outbound connection to the repositories, so I temporarily moved the network cable to a port on my switch that bypasses the firewall. I guess it's just weird that the system wouldn't just warn that it can't contact the repositories, rather than simply not running the app, or giving giving me any additional errors in the CLI. I'll figure out why pfsense is blocking that connection and make a bypass rule.