Page 1 of 1

Virtualbox not starting

Posted: Tue Apr 10, 2018 2:49 pm
by rgeorgia
I am having an issue with Virtualbox. I am using the latest version of GhostBSD (MATE). 11.1-RELEASE-p9 FreeBSD 11.1-RELEASE-p9.
I can only launch Virtualbox as root (sudo virtualbox). The icon in the menu does not work (permission denied).
Once virtualbox is running I imported a ovf file for my SANS class, which is Windows 10. The import completed, but when I tried to start the VM I got this error:
Failed to open a session for the virtual machine SANS504_Win10.

The virtual machine 'SANS504_Win10' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {85cd948e-a71f-4289-281e-0ca7ad48cd89}
Then in a dialog box I have this message:
Kernel driver not installed (rc=-1908)

Make sure the kernel module has been loaded successfully.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.
Most of what I found from google search dealt with Debian, Arch and a few other Linux distros. The FreeBSD related forums were targeted at FreeBSD 10.x

Any suggestions? It would be nice if I could complete my SANS course without having to install Windows on a spare computer.

Re: Virtualbox not starting  [SOLVED]

Posted: Tue Apr 10, 2018 5:49 pm
by rgeorgia
I found the issue, which was two fold. One, I added vboxdrv_load="YES" to boot/loader.conf. and I changed the default nework to NAT. Now it works.