installation from ports is unable to determine OS version  [SOLVED]

Installing and maintaining software with the FreeBSD Ports Collection.
Post Reply
ouaille_aime_scier_
Posts: 19
Joined: Sun Sep 01, 2019 1:38 pm
Has thanked: 0
Been thanked: 2 times

installation from ports is unable to determine OS version

Post by ouaille_aime_scier_ » Tue Sep 17, 2019 7:04 pm

Hello guys,

I tried to install a package from port sources, but the compilation fails about this message : make: "/usr/ports/Mk/bsd.port.mk" line 1160: Unable to determine OS version. Either define OSVERSION, install /usr/include/sys/param.h or define SRC_BASE.

I found in FreeBSD documentation that I can manually setenv OS version before compiling but I ignore wich value to define (12.x-RELEASE or -STABLE) ?

User avatar
ericbsd
Developer
Posts: 1396
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 36 times
Been thanked: 46 times

Re: installation from ports is unable to determine OS version

Post by ericbsd » Wed Sep 18, 2019 9:26 am

I would not recommend you to use ports unless you know what you do. To use ports you will need to install src and os-userland-devtools packages, also make sure to use https://github.com/ghostbsd/ghostbsd-ports.

ouaille_aime_scier_
Posts: 19
Joined: Sun Sep 01, 2019 1:38 pm
Has thanked: 0
Been thanked: 2 times

Re: installation from ports is unable to determine OS version  [SOLVED]

Post by ouaille_aime_scier_ » Wed Sep 18, 2019 5:36 pm

Thanks ericbsd I will try it.

ouaille_aime_scier_
Posts: 19
Joined: Sun Sep 01, 2019 1:38 pm
Has thanked: 0
Been thanked: 2 times

Re: installation from ports is unable to determine OS version

Post by ouaille_aime_scier_ » Fri Sep 20, 2019 12:19 pm

It works fine, I just need to install os-generic-userland-devtools :-) I wanted compiling exfat-utils to mount FAT32 usb key but I saw an other post here on the subject.

Post Reply