No sound on TV via HDMI

Support with sound and multimedia cards on GhostBSD
Post Reply
slawul
Posts: 8
Joined: Sun May 17, 2020 5:41 am
Has thanked: 0
Been thanked: 0

No sound on TV via HDMI

Post by slawul »

I raised the subject of the telegram several times, I promised that I would write how things are going.
I needed to connect my laptop to the TV via HDMI - I use MATE as an environment, so I checked the connections:

Code: Select all

 sysctl /dev/sndstat
pcm0: <Realtek ALC269 (Analog 2.0 + HP/2.0)> (play/rec) default
pcm1: <Realtek ALC269 (Internal Analog Mic)> (rec)
pcm2: <Intel Kaby Lake (HDMI/DP 8ch)> (play)
No devices installed from userspace. 
I changed the output setting:

Code: Select all

 sysctl hw.snd.default_unit = 2
hw.snd.default_unit: 0 -> 2 
Now there should be sound on the TV:

Code: Select all

 sysctl /dev/sndstat
pcm0: <Realtek ALC269 (Analog 2.0 + HP/2.0)> (play/rec)
pcm1: <Realtek ALC269 (Internal Analog Mic)> (rec)
pcm2: <Intel Kaby Lake (HDMI/DP 8ch)> (play) default
No devices installed from userspace. 
Unfortunately, the Sound Preferences did not change anything either.
What is it like in GhostBSD-XFCE? I downloaded and recorded it on a pendrive, pulseaudio as a sound server no pavucontrol and xfce4-pulseaudio-plugin - how to control the sound?
After some problems I was able to install everything I needed on live - the result is the same as on GhostBSD-MATE, the picture on TV via HDMI is sound, no sound only through the laptop speakers.
Here are some photos taken with the phone.

https://tinyurl.com/y56bdy2u
https://tinyurl.com/y4agzo2q
https://tinyurl.com/y5p92djr
https://tinyurl.com/y5qd6tz3
https://tinyurl.com/yycb9cz5

Knowing my previous experience, I decided to check what it looks like on Manjaro Linux.

https://tinyurl.com/y3m3p8bs
https://tinyurl.com/yypycrhh
https://tinyurl.com/y43acmju
https://tinyurl.com/y4z2zsak
https://tinyurl.com/y6tkdg6a

What's the problem on GhostBSD that sound doesn't work via HDMI on TV, and on Manjaro Linux you can even select the HDMI channel?

Post Reply