Completely broken audio in 20.08.1. Realtek ALC892.

Support with sound and multimedia cards on GhostBSD
Post Reply
CoatlessEskimo
Posts: 1
Joined: Fri Aug 28, 2020 6:23 pm
Has thanked: 0
Been thanked: 0

Completely broken audio in 20.08.1. Realtek ALC892.

Post by CoatlessEskimo »

I have made sure the sound driver is properly loaded. "cat /dev/sndstat" gives the following output:

Code: Select all

Installed devices:
pcm0: <ATI R6xx (HDMI)> (play)
pcm1: <ATI R6xx (HDMI)> (play)
pcm2: <ATI R6xx (HDMI)> (play)
pcm3: <ATI R6xx (HDMI)> (play)
pcm4: <ATI R6xx (HDMI)> (play)
pcm5: <ATI R6xx (HDMI)> (play)
pcm6: <Realtek ALC892 (Analog 8ch/2.0)> (play/rec)
pcm7: <Realtek ALC892 (Front Analog)> (play/rec) default
pcm8: <Realtek ALC892 (Rear Digital)> (play)
pcm9: <USB audio> (rec)
No devices installed from userspace.
I have tried manually setting the DSP device with "sysctl hw.snd.default_unit=X", with 'X' being the numbers 6 through 8. I want output through the front analog audio jack, and none of the jacks have worked with any default sound devices I've set. I have also tried using the MATE method of setting the default audio output. Also worth note is that when using /dev/dsp6-8, audacity crashes after trying to play a file. They seem to play correctly through the HDMI outputs. What can I do to resolve this problem?

wb7odyfred
Posts: 51
Joined: Sat Nov 12, 2016 5:44 pm
Has thanked: 0
Been thanked: 3 times

Re: Completely broken audio in 20.08.1. Realtek ALC892.

Post by wb7odyfred »

Sharing some Links to read about GhostBSD OSS sound

https://www.freebsd.org/doc/en_US.ISO88 ... k/oss.html
https://www.freebsd.org/doc/handbook/sound-setup.html FreeBSD handbook

https://www.davidschlachter.com/misc/freebsd-usb-audio USB Audio setup details
https://www.reddit.com/r/BSD/comments/6 ... lp_alc892/ ALC892 on Reddit

sysctl hw.snd.default_unit
sysctl hw.snd.default_unit=5

Looking around for more details to post a better setup your sound

https://unix.stackexchange.com/question ... em-to-work Some information may be helpful

Code: Select all

bindsym XF86AudioRaiseVolume exec mixer vol +2
bindsym XF86AudioLowerVolume exec mixer vol -2

https://www.leidinger.net/FreeBSD/dox/d ... ource.html FreeBSD Kernel Sound source code listing

https://unix.stackexchange.com/question ... ot-working Shows some setting for debug messages on sound chip

this sound chip is Intel HDA, but should work with debugging your Realtek Chip.

Post Reply