No volume control for sound and Preferences don't stick

Support with sound and multimedia cards on GhostBSD
Post Reply
lsitongia
Posts: 2
Joined: Fri Nov 02, 2018 2:40 pm
Has thanked: 0
Been thanked: 0

No volume control for sound and Preferences don't stick

Post by lsitongia » Fri Nov 02, 2018 3:28 pm

I'm trying 18.10 for the first time, with Mate. This is on a desktop PC with a Gigabyte motherboard and an NVidia 1070 Ti GPU card. dmesg says the sound is a Realtek ALC887. Sound works, but volume control does not work. I've tried the control in the upper right of the desktop and the Control Center preference. I have my speakers plugged into the MB rear audio output.

I've notice that this preference control doesn't stick. If I change the Input and Output devices, click Close, and open it back up, they are back to the default. Also, when I change the Output, the audio I have playing (through Firefox) at the time does not stop.

My system has a number of audio channels, pcm0 -> pcm8. I have a Microsoft Lifecam (which has a microphone), an Oculus Rift (mic and headphones), the MB Realtek (front, back, digital) and the NVidia apparently has four channels (for each HDMI and DisplayPort port?).

So, there's trouble with the Preferences control and the Volume control.

Thanks for your help! Let me know if I should report this as a bug.

lsitongia
Posts: 2
Joined: Fri Nov 02, 2018 2:40 pm
Has thanked: 0
Been thanked: 0

Re: No volume control for sound and Preferences don't stick

Post by lsitongia » Fri Nov 02, 2018 4:40 pm

I see that the volume control in MPlayer works.
The volume control in PulseAudio Volume Control works.

What is the correspondence between pcmN and /dev/dspN? The volume controls are for dsp0 and dsp4. If that corresponds to pcm0 and pcm4, then those are my NVidia card (one of the DisplayPort or HDMI ports in my GPU card?). If audio is supported over HDMI and DisplayPort, then I should be hearing sound on my display speakers (LG UHD).

Post Reply