Radeon Mobility HD 4200: Invisible Mouse Cursor

Help with graphics cards on GhostBSD.
Post Reply
sweeney
Posts: 4
Joined: Sun Jan 26, 2020 3:17 am
Has thanked: 0
Been thanked: 0

Radeon Mobility HD 4200: Invisible Mouse Cursor

Post by sweeney »

I have an interesting issue.
When I boot into GhostBSD 20.01 on my old Toshiba Satelitte, BSD does detect and uses the AMD Radeon Mobility 4200HD chipset (RS880) sucessfully, but I have a missing mouse cursor. You are still able to click and move the cursor, but it rather difficult to use as you cannot see it current location.
I installed GhostBSD using VESA mode and then installed the radeonkms driver using pkg. I have added kld_list="/boot/modules/radeonkms.ko" to rc.conf using sysrc but xorg does not use the driver. The driver seems loading as the console changes screen resolution but xorg does not recognise it. So currently I stuck at a lower screen resolution and without hardware acceleration.
The FreeBSD forums do mention a similar issue but I cannot get xorg to use the radeonkms driver in order to try the workaround. Can I edit the live ISO to try the workaround and reinstall?
https://forums.freebsd.org/threads/invi ... ter.70572/
https://bugs.freebsd.org/bugzilla/show_ ... ?id=237642

Any ideas?

sweeney
Posts: 4
Joined: Sun Jan 26, 2020 3:17 am
Has thanked: 0
Been thanked: 0

Re: Radeon Mobility HD 4200: Invisible Mouse Cursor

Post by sweeney »

I managed to get it working.
I had to change the /etc/X11/xorg.conf from "VESA" to "radeon" under the Section "Device" and rebooted. Done!

As per the following post:
https://forums.ghostbsd.org/viewtopic.p ... 7958#p7958

lucyanoraktrend
Posts: 4
Joined: Wed Mar 18, 2020 9:50 am
Has thanked: 0
Been thanked: 0

Re: Radeon Mobility HD 4200: Invisible Mouse Cursor

Post by lucyanoraktrend »

Quick clarification: select VESA/SMFB to install without the issue. Use "Legacy Compatibility" if you have issues with loading those. Once installed, you can install DRM-KMOD (you have to disable syscons and add the radeon driver to /etc/rc.conf) and/or do the above

Post Reply