WiFi Not Working

Help with setting up network cards, including WiFi cards.
gbar
Posts: 21
Joined: Wed Apr 05, 2017 12:30 pm
Has thanked: 0
Been thanked: 0

Re: WiFi Not Working

Post by gbar » Wed Aug 16, 2017 12:17 pm

Thanks but my terminal doesn't recognise networkmgr

NevilleGoddard
Developer
Posts: 394
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 3 times
Been thanked: 1 time

Re: WiFi Not Working

Post by NevilleGoddard » Thu Aug 17, 2017 9:38 am

Could you give me the output of

pkg -vv

?

gbar
Posts: 21
Joined: Wed Apr 05, 2017 12:30 pm
Has thanked: 0
Been thanked: 0

Re: WiFi Not Working

Post by gbar » Thu Aug 17, 2017 9:44 am

Certainly,
Version : 1.10.1
PKG_DBDIR = "/var/db/pkg";
PKG_CACHEDIR = "/var/cache/pkg";
PORTSDIR = "/usr/ports";
INDEXDIR = "";
INDEXFILE = "INDEX-10";
HANDLE_RC_SCRIPTS = false;
DEFAULT_ALWAYS_YES = false;
ASSUME_ALWAYS_YES = false;
REPOS_DIR [
"/etc/pkg/",
"/usr/local/etc/pkg/repos/",
]
PLIST_KEYWORDS_DIR = "";
SYSLOG = true;
ABI = "FreeBSD:10:amd64";
ALTABI = "freebsd:10:x86:64";
DEVELOPER_MODE = false;
VULNXML_SITE = "http://vuxml.freebsd.org/freebsd/vuln.xml.bz2";
FETCH_RETRY = 3;
PKG_PLUGINS_DIR = "/usr/local/lib/pkg/";
PKG_ENABLE_PLUGINS = true;
PLUGINS [
]
DEBUG_SCRIPTS = false;
PLUGINS_CONF_DIR = "/usr/local/etc/pkg/";
PERMISSIVE = false;
REPO_AUTOUPDATE = true;
NAMESERVER = "";
HTTP_USER_AGENT = "pkg/1.10.1";
EVENT_PIPE = "";
FETCH_TIMEOUT = 30;
UNSET_TIMESTAMP = false;
SSH_RESTRICT_DIR = "";
PKG_ENV {
}
PKG_SSH_ARGS = "";
DEBUG_LEVEL = 0;
ALIAS {
all-depends = "query %dn-%dv";
annotations = "info -A";
build-depends = "info -qd";
cinfo = "info -Cx";
comment = "query -i \"%c\"";
csearch = "search -Cx";
desc = "query -i \"%e\"";
download = "fetch";
iinfo = "info -ix";
isearch = "search -ix";
prime-list = "query -e '%a = 0' '%n'";
prime-origins = "query -e '%a = 0' '%o'";
leaf = "query -e '%#r == 0' '%n-%v'";
list = "info -ql";
noauto = "query -e '%a == 0' '%n-%v'";
options = "query -i \"%n - %Ok: %Ov\"";
origin = "info -qo";
provided-depends = "info -qb";
raw = "info -R";
required-depends = "info -qr";
roptions = "rquery -i \"%n - %Ok: %Ov\"";
shared-depends = "info -qB";
show = "info -f -k";
size = "info -sq";
}
CUDF_SOLVER = "";
SAT_SOLVER = "";
RUN_SCRIPTS = true;
CASE_SENSITIVE_MATCH = false;
LOCK_WAIT = 1;
LOCK_RETRIES = 5;
SQLITE_PROFILE = false;
WORKERS_COUNT = 0;
READ_LOCK = false;
PLIST_ACCEPT_DIRECTORIES = false;
IP_VERSION = 0;
AUTOMERGE = true;
VERSION_SOURCE = "";
CONSERVATIVE_UPGRADE = true;
PKG_CREATE_VERBOSE = false;
AUTOCLEAN = false;
DOT_FILE = "";
REPOSITORIES {
}
VALID_URL_SCHEME [
"pkg+http",
"pkg+https",
"https",
"http",
"file",
"ssh",
"ftp",
"ftps",
"pkg+ssh",
"pkg+ftp",
"pkg+ftps",
]
ALLOW_BASE_SHLIBS = false;
WARN_SIZE_LIMIT = 1048576;
METALOG = "";
NFS_WITH_PROPER_LOCKING = false;


Repositories:
FreeBSD: {
url : "pkg+http://pkg.FreeBSD.org/FreeBSD:10:amd64/quarterly",
enabled : yes,
priority : 0,
mirror_type : "SRV",
signature_type : "FINGERPRINTS",
fingerprints : "/usr/share/keys/pkg"
}

NevilleGoddard
Developer
Posts: 394
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 3 times
Been thanked: 1 time

Re: WiFi Not Working

Post by NevilleGoddard » Thu Aug 17, 2017 9:57 am

Thanks. I see by these lines:


Repositories:
FreeBSD: {
url : "pkg+http://pkg.FreeBSD.org/FreeBSD:10:amd64/quarterly",
enabled : yes,
priority : 0,
mirror_type : "SRV",
signature_type : "FINGERPRINTS",
fingerprints : "/usr/share/keys/pkg"


you're using the FreeBSD repository which I think is the source of probably most of your troubles.

You should change from the FreeBSD to the GhostBSD repositories. I am currently using GhostBSD 10.3 with the GhostBSD repositories on my laptop and everything is working fine.

Here's a link on how to change to the GhostBSD repositories if you wish to do so.

viewtopic.php?f=69&t=715

If you're familiar with creating files and folders in Unix I would recommend you change repositories.

If you need more directions or help please let me know.

On my main machine I'm using GhostBSD 11.1 which has the new repositories automatically enabled. :D

It is ALPHA but it is also is very stable and is working fine.

It can be downloaded from here:

http://www.ghostbsd.org/11.1-ALPHA1

Good luck.

gbar
Posts: 21
Joined: Wed Apr 05, 2017 12:30 pm
Has thanked: 0
Been thanked: 0

Re: WiFi Not Working

Post by gbar » Thu Aug 17, 2017 10:29 am

Cheers,
I wouldn't say I'm by any means competent but I've made the file and changed back to GhostBSD repository
I'll let you know how I get on
Thanks very much
Gbar

NevilleGoddard
Developer
Posts: 394
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 3 times
Been thanked: 1 time

Re: WiFi Not Working

Post by NevilleGoddard » Thu Aug 17, 2017 10:30 am

Can you give me the output of

pkg -vv

again?

gbar
Posts: 21
Joined: Wed Apr 05, 2017 12:30 pm
Has thanked: 0
Been thanked: 0

Re: WiFi Not Working

Post by gbar » Thu Aug 17, 2017 11:50 am

It's been updating for a while now, 477 of 999
Will reply later

NevilleGoddard
Developer
Posts: 394
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 3 times
Been thanked: 1 time

Re: WiFi Not Working

Post by NevilleGoddard » Thu Aug 17, 2017 12:06 pm

Good luck.

gbar
Posts: 21
Joined: Wed Apr 05, 2017 12:30 pm
Has thanked: 0
Been thanked: 0

Re: WiFi Not Working

Post by gbar » Fri Aug 18, 2017 5:22 pm

Well that was a bit of a disaster, it's wiped everything and won't boot at all now. It stalls at the 'GNU GRUB version 2.02 betas' page and every option returns
error: you need to load the kernel first.

Guess I'll be going for a complete fresh install

NevilleGoddard
Developer
Posts: 394
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 3 times
Been thanked: 1 time

Re: WiFi Not Working

Post by NevilleGoddard » Sat Aug 19, 2017 1:45 am

Sorry to hear that that happened. :(

It's very unusual.

Hope you have better luck with the new install.

Did you disable the FreeBSD repositories after enabling the GhostBSD repos?

Post Reply