[iwlwifi] No WiFi Interface shown up

Help with setting up network cards, including WiFi cards.
Post Reply
wix
Posts: 1
Joined: Tue Nov 15, 2022 12:53 am

[iwlwifi] No WiFi Interface shown up

Post by wix »

New to BSD. After a fresh install of GhostBSD 22.11.02 on my HP laptop with Intel WiFi chip for trials, there is no Wi-Fi interface shown up for connections. Any help would be highly appreciated!

Hardware

Code: Select all

> pciconf -l | grep iwm
iwm0@pci0:0:20:3:        class=0x028000  rev=0x30  hdr=0x00  vendor=0x8086  device=0x9df0  subvendor=0x8086  subdevice=0x0034

Configurations

Tried things mentioned at https://forums.ghostbsd.org/viewtopic.php?f=64&t=2417 but still no wlan0 appearing.


Symptoms

System boot log:

Code: Select all

......
Loading kernel modules:
Autoloading module: acpi_wmi
Autoloading module: if_iwlwifi
Autoloading module: if_iwm
Autoloading module: ig4
Autoloading module: pchtherm
ifconfig: SIOCIFCREATE2 (wlan0): Device not configured
Starting Network: lo0.
lo0: flags=8049<UP, LOOPBACK, RUNNING, MULTICAST> metric 0 mtu 16384
......

ifconfig -a only shows lo0 interface, not seeing wlan0


sudo sysctl net.wlan.devices shows nothing as:

Code: Select all

net.wlan.devices:
(not seeing any device listed after the colon)

sudo /etc/rc.d/netif start wlan0 shows

Code: Select all

ifconfig: SIOCIFCREATE2 (wlan0): Device not configured
Starting wpa_supplicant.
/etc/rc.d/wpa_supplicant: WARNING: failed to start wpa_supplicant
Starting Network: wlan0.
ifconfig: interface wlan0 does not exist
sudo kldload if_iwlwifi shows

Code: Select all

kldload: can't load if_iwlwifi: module already loaded or in kernel
sudo kldstat shows

Code: Select all

......
18    1  0xffffffff85748000     880c8  if_iwlwifi.ko
19    1  0xffffffff857d1000     17310  if_iwm.ko
......
wb7odyfred
Posts: 103
Joined: Sat Nov 12, 2016 5:44 pm

Re: [iwlwifi] No WiFi Interface shown up

Post by wb7odyfred »

I think these two drivers are conflicting with each other. I have a Intel Wireless iwm chipset in one computer. So I would remove iwlwifi driver

Code: Select all

kldunload if_iwlwifi
18 1 0xffffffff85748000 880c8 if_iwlwifi.ko
19 1 0xffffffff857d1000 17310 if_iwm.ko
https://wiki.freebsd.org/WiFi/Iwlwifi
https://wiki.freebsd.org/WiFi/Iwlwifi/Chipsets
https://forums.freebsd.org/threads/iwlw ... -up.87102/ Saw your FreeBSD forum post WIX with Sir Dice saying GhostBSD not supported here

Make sure you get the Wifi firmware loaded. That you have firmware in the proper directory, for the driver to automatically load it.

Code: Select all

pciconf -lv
usbconfig list
usbconfig -d ugenX.Y dump_device_desc
Where X and Y are numbers matching your USB Wifi device.

Looking for the exact Vendor and Product ID for the chipset in your pc

https://forums.freebsd.org/threads/rand ... ost-587546

https://wiki.freebsd.org/WiFi/Iwlwifi
Q: Which is the best supported chipset?
A: Not sure there is an answer. Based on demand I am currently mostly testing on AX200 and AX210.

Q: Does this driver support the AX210 from the Framework Laptop?

A: Yes it does.

Q: Upon start we associate and immediately drop back and associate again. What is going on there?
A: After associating the firmware/driver reports beacon losses or connection loss and subsequently we take the state down to recover. On second attempt we seem to usually succeed.
A: It is unclear as to where this behavior comes from but similar reports were seen from Linux users in the last two years and speculations are that it could be a firmware issue.




Q: How do I stop devmtach from automatically loading if_iwlwifi?
A: Add devmatch_blocklist="if_iwlwifi" to rc.conf.
A: Similar you can also prevent iwm(4) from being loaded if you want to try iwlwifi(4).


There is a Helpmywifigo.sh file on the Telegram Channel. Just search there. That will get the required documentation when run chmod +x helpmywifigo.sh ; sh helpmywifigo.sh >my_iwlwifi_wix.txt

bsd-hardware.info and linux-hardware.org are useful to help find device drivers

https://linux-hardware.org/?view=search ... ax201#list
https://bsd-hardware.info/?id=pci:8086-02f0-8086-0070
https://bsd-hardware.info/?view=search& ... =9df0#list
https://bsd-hardware.info/?id=pci:8086-9df0-8086-0030 Supported by FreeBSD 12.1 and later

FreeBSD


The device is supported by FreeBSD versions 12.2 and newer:


Ver Source Config By ID By Class
12.2 - 14-CURRENT sys/dev/iwm/if_iwm.c - 8086:9df0 *

https://github.com/freebsd/freebsd-src/ ... m/if_iwm.c Firmware file needs to be loaded for your device id

https://www.freebsd.org/cgi/man.cgi?iwm(4)


Join a specific BSS network with network name "my_net":

ifconfig wlan create wlandev iwm0 ssid my_net up


Alternatively, to load the driver as a module at boot time, place the
following lines in loader.conf(5):

if_iwm_load="YES"
iwm3160fw_load="YES"
iwm3168fw_load="YES"
iwm7260fw_load="YES"
iwm7265fw_load="YES"
iwm8000Cfw_load="YES"
iwm8265fw_load="YES"
iwm9000fw_load="YES"
iwm9260fw_load="YES"

DESCRIPTION
The iwm driver provides support for:

Intel Dual Band Wireless AC 3160
Intel Dual Band Wireless AC 3165
Intel Dual Band Wireless AC 3168
Intel Dual Band Wireless AC 7260
Intel Dual Band Wireless AC 7265
Intel Dual Band Wireless AC 8260
Intel Dual Band Wireless AC 8265
Intel Dual Band Wireless AC 9260
Intel Dual Band Wireless AC 9270
Intel Dual Band Wireless AC 946X
Intel Dual Band Wireless AC 9560

Currently, iwm only supports 802.11b and 802.11g modes. It will not as-
sociate to access points that are configured to operate only in 802.11n or 802.11ac modes.

https://www.freebsd.org/cgi/man.cgi?que ... +and+Ports
Post Reply