How to Fix Mouse Scrolling

Support for other hardware categories not listed below.
Post Reply
fmh
Posts: 98
Joined: Wed Jul 23, 2014 2:07 pm

How to Fix Mouse Scrolling

Post by fmh »

This annoying feature came back into version 11.1 of GhostBSD after being away for a couple of releases. Now that I use GhostBSD more it really bothers and I have not been able to find out how to correct it yet. In all versions of 11.1 that I have tried of Mate including Betas etc is that the Mouse Scroll wheel works properly when scrolling down but if you scroll up it is configured as a Backspace key. Behaviour is that when on a Web page instead of scrolling to the top of the page it goes to the previous page. When in other non Web Browser apps or on the Desktop the same thing happens when using the scroll up to get to the top of the list it goes back to the previous page, app, etc.

How do I turn off this behaviour? It was in 10.3 I believe and then was fixed until 11.1. I looked in Mouse and Keyboard settings and can not find where this is configured. I am using 11.1 64bit Mate install.
User avatar
ericbsd
Developer
Posts: 1774
Joined: Mon Nov 19, 2012 7:54 pm

Re: How to Fix Mouse Scrolling

Post by ericbsd »

Remove moused in /etc/rc.conf that is the problem.
User avatar
slughorn
Posts: 135
Joined: Mon Oct 02, 2017 2:55 pm

Re: How to Fix Mouse Scrolling

Post by slughorn »

fmh wrote:This annoying feature came back into version 11.1 of GhostBSD after being away for a couple of releases. Now that I use GhostBSD more it really bothers and I have not been able to find out how to correct it yet. In all versions of 11.1 that I have tried of Mate including Betas etc is that the Mouse Scroll wheel works properly when scrolling down but if you scroll up it is configured as a Backspace key. Behaviour is that when on a Web page instead of scrolling to the top of the page it goes to the previous page. When in other non Web Browser apps or on the Desktop the same thing happens when using the scroll up to get to the top of the list it goes back to the previous page, app, etc.

How do I turn off this behaviour? It was in 10.3 I believe and then was fixed until 11.1. I looked in Mouse and Keyboard settings and can not find where this is configured. I am using 11.1 64bit Mate install.
I had the same issue. See here:viewtopic.php?f=59&t=928&start=10. The tip of ericbsd has solved my problem. :mrgreen:
fmh
Posts: 98
Joined: Wed Jul 23, 2014 2:07 pm

Re: How to Fix Mouse Scrolling

Post by fmh »

I do have a problem when trying to do this. The rc.conf file is Read Only.

What I did was to go into the terminal and go to the /etc folder
I typed sudo chmod +w rc.conf
get prompted for the password and enter it in successfully
but the rc.conf is still Read Only.

I also tried sudo chmod u+w rc.conf

but that did not add Write access.

Obviously Unix 101 here but what am I missing?
Hecktor
Posts: 27
Joined: Thu Dec 21, 2017 2:43 pm

Re: How to Fix Mouse Scrolling

Post by Hecktor »

It is read only because you don't have rights to write to it with your account.

Type the following:
sudo ee /etc/rc.conf

Escape brings up a menu so you can save it.
fmh
Posts: 98
Joined: Wed Jul 23, 2014 2:07 pm

Re: How to Fix Mouse Scrolling

Post by fmh »

Thank You that did it.

I thought I had to change the file to Write status before I could call it up to change it. All is good now.
Mach28-5?
Posts: 8
Joined: Sat Jan 14, 2017 9:23 pm

Re: How to Fix Mouse Scrolling

Post by Mach28-5? »

ericbsd wrote: Tue Nov 28, 2017 12:48 pm Remove moused in /etc/rc.conf that is the problem.
I have this same problem using GhostBSD in VirtualBox 6.1. What would the answer be if moused is already not in the rc.conf file? Thanks.
mogplus8
Posts: 2
Joined: Wed May 26, 2021 12:48 am

Re: How to Fix Mouse Scrolling

Post by mogplus8 »

Same for me, running in Virtualbox 6.1 (host system Linux Mint). Scroll up causes page back if positioned at the top of the page. Positioned further down it usually works correctly. I have also noticed that the Backspace key causes a page back if the cursor is in the search box. Makes it hard to correct typos when typing in search criteria...
:-\
mogplus8
Posts: 2
Joined: Wed May 26, 2021 12:48 am

Re: How to Fix Mouse Scrolling

Post by mogplus8 »

Forgot to mention I also don't have moused in the /etc/rc.conf file.
User avatar
ericbsd
Developer
Posts: 1774
Joined: Mon Nov 19, 2012 7:54 pm

Re: How to Fix Mouse Scrolling

Post by ericbsd »

mogplus8 wrote: Thu May 27, 2021 1:03 am Forgot to mention I also don't have moused in the /etc/rc.conf file.
GhostBSD does not start services in /etc/rc.conf. GhostBSD is not FreeBSD. It is base on FreeBSD.

To remove moused do:

Code: Select all

rc-update delete moused
Post Reply