Windows 10 & GhostBSD

Post your general questions or comments about GhostBSD here!
hank2000
Posts: 253
Joined: Mon Sep 16, 2013 9:42 am
Has thanked: 2 times
Been thanked: 1 time

Re: Windows 10 & GhostBSD

Post by hank2000 » Tue Nov 28, 2017 8:36 am

that sthe problem mate: I DID not chnage anything, just repeated that GhostBSD install over the openSuse install, leaving Win 10 aside and with the config. You told me:
- UFS custom
- freeBSD loader + boot manager with two partitions / & swap!
suddenly I had a starting Win10 on F1, a starting GhostBSD til welcome screen and then the freebsd loader hang until complete shutdown and new boot!
try now again and then attach the pciconf screenshot; as I expected, something from Qualcom as wlan adapter.
ok, worked again, strange....
Attachments
20171128_132608_resized_1.jpg

hank2000
Posts: 253
Joined: Mon Sep 16, 2013 9:42 am
Has thanked: 2 times
Been thanked: 1 time

Re: Windows 10 & GhostBSD

Post by hank2000 » Tue Nov 28, 2017 8:38 am

sorry, hard to take a pic with smartphone, and hard to concentrate when exactly at noon children start stumping above Yr head every day. :(((

hank2000
Posts: 253
Joined: Mon Sep 16, 2013 9:42 am
Has thanked: 2 times
Been thanked: 1 time

Re: Windows 10 & GhostBSD

Post by hank2000 » Tue Nov 28, 2017 8:43 am

alright, in FreeBSD forums it says, that Qualcomm QCA9377.ac adapter isn t supported yet!
should I try with my Dlink one that should work or is support alternatively poss. under GhostBSD?

best
Achim

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: Windows 10 & GhostBSD

Post by ASX » Tue Nov 28, 2017 9:12 am

hank2000 wrote:alright, in FreeBSD forums it says, that Qualcomm QCA9377.ac adapter isn t supported yet!
should I try with my Dlink one that should work or is support alternatively poss. under GhostBSD?

best
Achim
Go with the dlink dongle, we don't write device drivers. ;)

hank2000
Posts: 253
Joined: Mon Sep 16, 2013 9:42 am
Has thanked: 2 times
Been thanked: 1 time

Re: Windows 10 & GhostBSD

Post by hank2000 » Tue Nov 28, 2017 9:20 am

ASX wrote:
hank2000 wrote:alright, in FreeBSD forums it says, that Qualcomm QCA9377.ac adapter isn t supported yet!
should I try with my Dlink one that should work or is support alternatively poss. under GhostBSD?

best
Achim
Go with the dlink dongle, we don't write device drivers. ;)
LOL - give it a try and let You know!

thx
Achim

hank2000
Posts: 253
Joined: Mon Sep 16, 2013 9:42 am
Has thanked: 2 times
Been thanked: 1 time

Re: Windows 10 & GhostBSD

Post by hank2000 » Tue Nov 28, 2017 12:11 pm

took some adjustments and a new start to finish, but: TADAAAA...:-D

best
Achim

last thing now to find out: couldn t update GhostBSD via OktoPkg:
it says:
"pkg: Repository GhostBSD load error: access repo file(/var/db/pkg/repo-GhostBSD.sqlite) failed: No such file or directory" and:
"pkg: http://pkg.GhostBSD.org/GhostBSD-11/amd ... t/meta.txz: No address record"
then OktoPkg hangs!
---> ok,the hanging, it was a major upd and it took some time! ;)
but the update station didn t start as well.... so have to try out here as well, but at LEAST: dual boot AND wlan, jay!!! :-D

Achim

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: Windows 10 & GhostBSD

Post by ASX » Tue Nov 28, 2017 1:04 pm

"No address record" means your dns settings are incorrect:

Likely you can successfully ping an IP address

Code: Select all

ping 8.8.8.8
but you cannot ping a URL:

Code: Select all

ping www.google.com
If that is the case, like it seems, add this to your /etc/resolv.conf:

Code: Select all

nameserver 8.8.8.8
nameserver 8.8.4.4
then restart the network interface:

Code: Select all

sudo netif restart
sudo routing restart
now try to use the internet ...

hank2000
Posts: 253
Joined: Mon Sep 16, 2013 9:42 am
Has thanked: 2 times
Been thanked: 1 time

Re: Windows 10 & GhostBSD

Post by hank2000 » Tue Nov 28, 2017 1:30 pm

Hi

seems, I can use it completely now after last major update of GhostBSD. even ping of www.google.de works now.
just, when trying to sychronize databases with OktoPkg I get:

"Updating GhostBSD repository catalogue...
pkg: http://pkg.GhostBSD.org/GhostBSD-11/amd ... t/meta.txz: No address record
repository GhostBSD has no meta file, using default settings
pkg: http://pkg.GhostBSD.org/GhostBSD-11/amd ... gesite.txz: No address record
Unable to update repository GhostBSD
Error updating repositories!"
when I repeat it one or two times it works!

2nd is: Laptop gets pretty hot or warm and I have to test this with Windows, maybe some adjustments to be made with the fan as well.....?

best
Achim

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: Windows 10 & GhostBSD

Post by ASX » Tue Nov 28, 2017 2:02 pm

hank2000 wrote:Hi

seems, I can use it completely now after last major update of GhostBSD. even ping of http://www.google.de works now.
just, when trying to sychronize databases with OktoPkg I get:

"Updating GhostBSD repository catalogue...
pkg: http://pkg.GhostBSD.org/GhostBSD-11/amd ... t/meta.txz: No address record
repository GhostBSD has no meta file, using default settings
pkg: http://pkg.GhostBSD.org/GhostBSD-11/amd ... gesite.txz: No address record
Unable to update repository GhostBSD
Error updating repositories!"
when I repeat it one or two times it works!
that's a strange behavior ...
2nd is: Laptop gets pretty hot or warm and I have to test this with Windows, maybe some adjustments to be made with the fan as well.....?
yes, something can be done:
in /etc/rc.conf:

Code: Select all

powerd_flags="-a adp -b adp -n adp"
powerd_enable="YES"
check the powerd man page for further details, have fun! ;)

hank2000
Posts: 253
Joined: Mon Sep 16, 2013 9:42 am
Has thanked: 2 times
Been thanked: 1 time

Re: Windows 10 & GhostBSD

Post by hank2000 » Tue Nov 28, 2017 4:10 pm

Hi ASX

well, after finishing some adjustments and several reboots I could find some reproducible behaviour:

- when starting Win10 with F1 and working with it and then restarting laptop and press F2 the boot process hangs with the welcome screen and the turning slash stands still;
in two cases the bios screen appeared, maybe pressed F2 too early but I think, it s about a milli sec in which there s confusion for system if it s BIOS or boot screen with F1/F2 for the computer systens.
when I start two or three times after these probs by using "shutdown" or by cold start before, THEN the countdown appears for 10 secs and booting starts!
when start hangs with welcome screen, there s NO countdown shown.

- the error messages of OktoPkg are reproducible when wlan was disabled at login/desktop start but is re-enabled by network manager, after GhostBSD finished with desktop login, strange thing is, one time desktop starts WITH wlan enabled, next time it s off!?
I then press the synchronization button with OktoPkg 2x/3x and then it runs till I get "command finishes with ok" or something similar...

- some menu entries show no reaction when pressed, for ex. update station or midnight commander but will further test this...

on the hardware temperature side the laptop gets hotter than with Win10, so guess, really have to adjust some settings, thx for the hints in /etc/rc.conf et al, will take a look at that tomorrow.
same with the other hints You gave me...

is there a good graphical tool or panel app, that shows CPU as well as harddisk temp., can t rem. the names but there was s.th. ...

best
Achim

Post Reply