virtualbox not available in repos

Post your general questions or comments about GhostBSD here!
Post Reply
Posts: 2
Joined: Tue Aug 02, 2022 6:36 am

virtualbox not available in repos

Post by kghosh22 »

Why is virtualbox-ose missing from the repos?
Virtualbox-ose-kmod and virtualbox-ose-additions are present, but no virtualbox-ose.
I tried in both oktopkg and in software station, both are not showing virtualbox-ose.

It is available in ports.
I tried installing /emulators/virtualbox-ose from ports, but it failed with:

===> FAILED Applying FreeBSD
===> FAILED to apply cleanly FreeBSD patch(es)
*** Error code 1

Any help will be appreciated.

I am a new user of GhostBSD, but a long time user of Linux Debian.
I have earlier installed virtualbox on GhostBSD, but after reinstalling GhostBSD, I can no longer find virtualbox-ose.

Thanks in advance,
K. Ghosh
User avatar
Posts: 1968
Joined: Mon Nov 19, 2012 7:54 pm

Re: virtualbox not available in repos

Post by ericbsd »

Thanks for reporting I fixed the port this morning ... b670f2dc11.

I will build the package.
Posts: 2
Joined: Tue Aug 02, 2022 6:36 am

Re: virtualbox not available in repos

Post by kghosh22 »

Thanks, Virtualbox-ose is now available in the repos.
However, trying to install it fails with the message:

[1/6] Installing lzo2-2.10_1...
[1/6] Extracting lzo2-2.10_1: 100%
[2/6] Installing sdl-1.2.15_15,2...
[2/6] Extracting sdl-1.2.15_15,2: 100%
[3/6] Installing virtualbox-ose-kmod-6.1.36...
[3/6] Extracting virtualbox-ose-kmod-6.1.36: 100%
kldload_vbox: vboxdrv -> vboxdrv
vboxnet_enable: YES -> YES
kldload: can't load vboxdrv: module already loaded or in kernel
eval: /usr/local/bin/VBoxManage: not found
/bin/sh: rc-update: not found
[4/6] Installing libvncserver-0.9.13_1...
[4/6] Extracting libvncserver-0.9.13_1: 100%
[5/6] Installing libIDL-0.8.14_5...
[5/6] Extracting libIDL-0.8.14_5: 100%
[6/6] Installing virtualbox-ose-6.1.36...
===> Creating groups.
Using existing group 'vboxusers'.
===> Creating users
Creating user 'vboxusers' with uid '920'.
pw: group `920' does not exist
pkg: PRE-INSTALL script failed

I don't find VBoxManage or rc-update in the repos.
Am I doing something wrong?

Thanks in advance.
K. Ghosh
Post Reply