Startup Fails on Setting Date via NTP

Questions and support problems dealing directly with the FreeBSD Operating System.
Post Reply
Larryd
Posts: 2
Joined: Sun Aug 04, 2019 7:40 pm
Has thanked: 0
Been thanked: 1 time

Startup Fails on Setting Date via NTP

Post by Larryd »

Startup Fails on Setting Date via NTP..Then name server cannot be used..Then non recoverable failure in name resolution.
GhostBSD version 19.04. Installed in VMware Workstation 15 as a virtual machine.

The install went perfectly and first reboot worked perfectly and startup went to the Mate Desktop but after the next
restart we are stuck at the shell. We can login to the shell and run startx and system continues to the Mate Desktop.

Have done google searches and read some Freebsd troubleshooting for the same errors but so far no solution to this issue.

Any recommendations would be appreciated.

Huck
Posts: 8
Joined: Mon Aug 03, 2020 10:17 am
Has thanked: 0
Been thanked: 0

Re: Startup Fails on Setting Date via NTP

Post by Huck »

I have a different version of the same problem. The time and date manager seems to be not connected to anything, and several time related issues crop up: Error message on starting the time and date manager app, then the app loads but the controls are all greyed out. Time is set properly in BIOS and the Mate tray app, but the lock screen time shown is 7b hours fast. About every third boot up the OS stops at the shell and requires login and startx.

ouaille_aime_scier_
Posts: 66
Joined: Sun Sep 01, 2019 1:38 pm
Has thanked: 0
Been thanked: 8 times

Re: Startup Fails on Setting Date via NTP

Post by ouaille_aime_scier_ »

On my side I have installed chrony in remplacement of ntp and all is good !

mapsware
Posts: 29
Joined: Tue May 07, 2019 11:22 pm
Location: Hermosillo, Son. Mexico
Has thanked: 2 times
Been thanked: 1 time

Re: Startup Fails on Setting Date via NTP

Post by mapsware »

I don't know how to solve the problem, but I understand what it is and what should be done

The problem is that NTP runs before name resolution (nsswitch) is available

GhostBSD use OpenRC for the init system, start by looking for how to configure the run dependency on OpenRC

An alternative solution would be to use IP addresses in /etc/ntp.conf or register the server names in /etc/hosts

Post Reply