Page 1 of 1

Configuring Grub 2 to include GhostBSD

Posted: Mon Apr 25, 2016 2:39 am
by billwx
Hi all,
As a Linux user new to BSD Ghost has so far been the easiest for me to install and use. Very nice distro. Problem is i have locked myself out of Ghost by installing linux afterward. I have a bios and am using legacy msdos partitioning, all 4 primary. I have Ghost on partition 3, Sabayon Linux on part 4, Linux Swap on part 2, and Antergos Linux on the first partition, having installed it last and using its Grub to boot.

With an earlier setup of only Arch and Ghost i was advised to add this to my Arch grub.cfg

menuentry "GhostBSD"{
set root=(hd0,msdos1)
chainloader +1

Once i changed msdos1 to msdos3 (as Ghost was in the third partition) things worked great.

Doing the same thing on the same Dell e5420 laptop but different OS setup now gives me "invalid signature" error when i try to boot into Ghost.
Can anyone tell me what that error means? Would it matter that I'm using a third OS whereas before i had only two and a swap part?
And until i get this fixed, I'd love to know the path and name of the kernel file Grub needs to boot Ghost via special instructions at startup. Thanks for any advice!


Re: Configuring Grub 2 to include GhostBSD

Posted: Mon Apr 25, 2016 5:30 am
by ericbsd
On any Linux I have use I add this:

Code: Select all

menuentry "GhostBSD"{
set root=(hd0,3)
chainloader +1

SOLVED: Re: Configuring Grub 2 to include GhostBSD

Posted: Tue Apr 26, 2016 4:26 am
by billwx
Finally i have a dual-boot Antergos - GhostBSD system!

I was using the syntax you suggested, but just to be sure i hadn't missed something i did a quick copy/paste of your example. Same result "Invalid Signature."

When this worked before i had been using Arch, installed with the help of Architect. So i reinstalled that os in a small partition 4 and edited its grub.cfg. Same result.

Finally i decided something must be wrong with my Ghost, then i recalled this one difference- during the first install when dual boot worked for me i installed GhostBSD and the BSD bootloader. I then wrote over that with Arch Grub 2. When it did not work, i had installed BSD with its Grub to the MBR, and overwrote that with Antergos Grub. Figuring nothing to lose i reinstalled Ghost and its BSD bootloader, then installed the Antergos Grub 2 over it in MBR. Voila, my modified grub.cfg boots both os's just fine.

How could it possibly matter whether one installs BSD Bootloader or BSD's Grub into MBR only to wipe it out by the Grub of a linux i have no idea, yet that *seems* to be what happened. In case anyone is wondering, "Linux" showed up in my BSD Bootloader and in it's Grub but neither would boot it. Having even less idea how to configure such options in BSD i stuck with the Linux booter.

The important thing, besides learning of course, is i can use Antergos for the things I've yet to accomplish on BSD. Top of the list- wifi, then printer, then hopefully wifi printer...