update error message - OS related mismatch

Questions about the installation of FreeBSD
Post Reply
nevets
Posts: 11
Joined: Tue Jun 23, 2020 3:54 am
Has thanked: 2 times
Been thanked: 1 time

update error message - OS related mismatch

Post by nevets »

Hi,
Executing pkg update -f
we get...
=======================================
Updating GhostBSD repository catalogue...
Fetching meta.conf: 100% 163 B 0.2kB/s 00:01
Fetching packagesite.txz: 100% 6 MiB 572.5kB/s 00:11
Processing entries: 0%
Newer FreeBSD version for package p5-Statistics-Frequency:
To ignore this error set IGNORE_OSVERSION=yes
- package: 1201519
- running kernel: 1201513
Ignore the mismatch and continue? [Y/n]:
=======================================
If I accept [Y] to ignore the OS mismatch and continue, the update finishes fine, however, on rebooting the desktop doesn't load [I'm left hanging at the FreeBGSD login prompt].

Would welcome advice please.

Steve

--------------------------
Nominal Data before update...

OS release: FreeBSD 12.1-STABLE
Machine class: amd64
CPU Model: Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz
System memory available: 8034 MB
Currently loaded kernel modules:
kernel
zfs.ko
opensolaris.ko
geom_eli.ko
aesni.ko
tmpfs.ko
geom_uzip.ko
xz.ko
fdescfs.ko
fuse.ko
ums.ko
linux.ko
linux_common.ko
linux64.ko
cuse.ko
amdgpu.ko
drm.ko
linuxkpi.ko
linuxkpi_gplv2.ko
debugfs.ko
ttm.ko
radeonkms.ko
i915kms.ko
i915_skl_dmc_ver1_27_bin.ko
linprocfs.ko
ipfw.ko
Running services
avahi_daemon
avahi_dnsconfd
cupsd
dbus
devd
lightdm

User avatar
ericbsd
Developer
Posts: 1568
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 52 times
Been thanked: 84 times

Re: update error message - OS related mismatch

Post by ericbsd »

nevets wrote:
Wed Jul 22, 2020 8:41 pm
Updating GhostBSD repository catalogue...
Fetching meta.conf: 100% 163 B 0.2kB/s 00:01
Fetching packagesite.txz: 100% 6 MiB 572.5kB/s 00:11
Processing entries: 0%
Newer FreeBSD version for package p5-Statistics-Frequency:
To ignore this error set IGNORE_OSVERSION=yes
- package: 1201519
- running kernel: 1201513
Ignore the mismatch and continue? [Y/n]:
When you get this press yes and use pkg upgrade -f to upgrade and reinstall all the packages that have been compiled with the new kernel.

nevets
Posts: 11
Joined: Tue Jun 23, 2020 3:54 am
Has thanked: 2 times
Been thanked: 1 time

Re: update error message - OS related mismatch

Post by nevets »

Hi Eric,
Unfortunately, doing pkg upgrade -f causes the GhostBSD login to keep recycling - the desktop doesn't fire up.
I checked with a new HDD using fresh install of 20.04 (last release) and then forcing upgrade of this - with same result.
There's something iffy about the current GhostBSD build for my PC.
I'll refrain from updating pkgs until there's a fix.
Steve

User avatar
ericbsd
Developer
Posts: 1568
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 52 times
Been thanked: 84 times

Re: update error message - OS related mismatch

Post by ericbsd »

here is the latest ISO http://download.us.ghostbsd.org/develop ... 64/latest/ you can try that it was build today with the latest packages.
These users thanked the author ericbsd for the post:
nevets (Sun Jul 26, 2020 3:12 am)
Rating: 33.33%

nevets
Posts: 11
Joined: Tue Jun 23, 2020 3:54 am
Has thanked: 2 times
Been thanked: 1 time

Re: update error message - OS related mismatch

Post by nevets »

Thanks Eric,
Both MATE and XFCE install properly from your 24th July build. :-)
So I assume the issue lies in the incremental pkg update process...
Steve

User avatar
ericbsd
Developer
Posts: 1568
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 52 times
Been thanked: 84 times

Re: update error message - OS related mismatch

Post by ericbsd »

With some major changes, a new ISO is needed.

linunix
Posts: 13
Joined: Tue Apr 14, 2020 3:44 pm
Has thanked: 0
Been thanked: 1 time

Re: update error message - OS related mismatch

Post by linunix »

ericbsd wrote:
Sun Jul 26, 2020 9:06 pm
With some major changes, a new ISO is needed.
hi Eric
What do you mean "a new ISO is needed"? Should we re-install the whole OS?
Or we are able to upgrade currrent OS from this ISO?
Thanks

User avatar
ericbsd
Developer
Posts: 1568
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 52 times
Been thanked: 84 times

Re: update error message - OS related mismatch

Post by ericbsd »

linunix wrote:
Sat Aug 01, 2020 4:02 am
ericbsd wrote:
Sun Jul 26, 2020 9:06 pm
With some major changes, a new ISO is needed.
hi Eric
What do you mean "a new ISO is needed"? Should we re-install the whole OS?
Or we are able to upgrade current OS from this ISO?
Thanks
If you did install and the upgrade went fine. There is no need to reinstall if you have a problem from upgrading with `sudo pkg update -f` and `sudo upgrade -f` I would recommend to backup and reinstall.

linunix
Posts: 13
Joined: Tue Apr 14, 2020 3:44 pm
Has thanked: 0
Been thanked: 1 time

Re: update error message - OS related mismatch

Post by linunix »

ericbsd wrote:
Tue Aug 04, 2020 9:04 am
linunix wrote:
Sat Aug 01, 2020 4:02 am
ericbsd wrote:
Sun Jul 26, 2020 9:06 pm
With some major changes, a new ISO is needed.
hi Eric
What do you mean "a new ISO is needed"? Should we re-install the whole OS?
Or we are able to upgrade current OS from this ISO?
Thanks
If you did install and the upgrade went fine. There is no need to reinstall if you have a problem from upgrading with `sudo pkg update -f` and `sudo upgrade -f` I would recommend to backup and reinstall.
Thank you Eric.
Just tried `sudo pkg update -f` and `sudo pkg upgrade -f` and it's not working.
Might be new reinstall is the unique solution.

Post Reply