Failing to boot after install

Questions about the installation of FreeBSD
jcpollman
Posts: 25
Joined: Sat Dec 07, 2019 11:17 am
Has thanked: 0
Been thanked: 0

Re: Failing to boot after install

Post by jcpollman »

The new version does not ask - it just boots up, eventually, to the graphical interface - very slick

coqui
Posts: 2
Joined: Wed Dec 04, 2013 2:21 pm
Has thanked: 0
Been thanked: 0

Re: Failing to boot after install

Post by coqui »

Well, I came back after failing with v19.whatever. I read that Virtual Box has finally figured out how to work with BSD, so I thought I'd give it another try. I began with the xfce flavor of v20.0.4 because I'm more familiar with xfce than I am with mate, and I'm used to having 4 screens and a few of the xfce applets available. So I tried that. Five times, paying closer and closer attention trying to determine why it failed. I never could -- everything seemed to work as it should (though I have to say that it takes a loooong time with no feedback, not even a clock cursor to give some hint there's something going on. But eventually the loading window just vanished and the screen sat blank with no activity. The first time I rebooted quickly. On my last try I let it sit idle for 5 minutes. But I never got a message saying it was finished. I rebooted it from a terminal, pulling out the (virtual) CD from the (virtual) drive so it could boot from wherever it was supposed to -- but it couldn't find anything to boot from. It looked everywhere, finally throwing its hands up in disgust, as I also did.

Then I tried the mate flavor, figuring that if the developer favored this one, it should work. And in fact it did install. It . . . took . . . a . . .long . . . time, but it did work, finally telling me it was complete and that I could restart. When I did, it found a boot record and booted up nicely.

I like that I can resize the window in this release -- the version of VB Guest Additions that's installed is evidently reasonably current. It's not perfect, though. I can't share the mouse with the surrounding host, and I can't cut and paste across the system boundary. I also can't share storage, but that may be a function of BSD's ZFS file system working with the linux/windows file systems I have that I'd like to share.

VBox tells me that there is a more recent version of guest additions available and I should get the guest OS to install that. After upgrading (92 packages. 46 minutes.) I find that I have no idea what BSD calls the VB guest additions. None of my guesses came close.

But hey! I have a full-screen BSD now. Even though the font is so small I have to squint, and my track-pad mouse (I'm using a Lenovo T510) is extremely fast and jerky (and the system settings say it's as slow as possible) -- I have a full-screen BSD! Maybe with time and patience I can figure out how to use it.

Thanks to all who made this possible. Please keep up the good work.

Post Reply