Failing to boot after install

Questions about the installation of FreeBSD
jcpollman
Posts: 13
Joined: Sat Dec 07, 2019 11:17 am
Has thanked: 0
Been thanked: 0

Failing to boot after install

Post by jcpollman »

I used to be able to install Ghost, but not any more.

The install process goes as before, but after installing, when I select GhostBsD at bootup, I get a number of:
Setting currdev to disk2pX where X goes from 1 to 5 (listing all of them in turn)
Eventually it says: Failed to find bootable partition
Can't load 'kernel'

Additional info:
When I select the UEFI startup menu, I have both Ghostbsd and a UEFI OS entries - both of which give me the same results
I have used both the FreeBSD bootload, and the refind bootload - same results
I use a USB stick to install - I have over a dozen sticks and have tried most of them - same results
The computer has 32 gigs of ram. I have an AMD zen processor
I am install Ghost on an SSD with 500 gigs of space. I have used both UFS and ZFS
As it starts to install, it says: [:UEFI unexpected operator

Thoughts?

User avatar
slughorn
Posts: 107
Joined: Mon Oct 02, 2017 2:55 pm
Location: Grimma / Germany
Has thanked: 11 times
Been thanked: 8 times

Re: Failing to boot after install

Post by slughorn »

Will it help if you disable UEFI in your BIOS?

ouaille_aime_scier_
Posts: 47
Joined: Sun Sep 01, 2019 1:38 pm
Has thanked: 0
Been thanked: 6 times

Re: Failing to boot after install

Post by ouaille_aime_scier_ »

Hello jcpollman,

The warning message with "unexpected UEFI operator" does not prevent the installation of the distribution.
As Slughorn says, try installing Ghost in bios mode to see if it changes anything.
Also check whether, in UEFI mode, you have created a GPT partition table with an EFI partition under a VFAT file system.
At worst you can try a default installation with the installer.

jcpollman
Posts: 13
Joined: Sat Dec 07, 2019 11:17 am
Has thanked: 0
Been thanked: 0

Re: Failing to boot after install

Post by jcpollman »

I can't go fully into bios mode - but I used CSM. Exactly the same problem.

I should add that I have tried the regular version, the XFCE version, and the developmental release.
JC

jcpollman
Posts: 13
Joined: Sat Dec 07, 2019 11:17 am
Has thanked: 0
Been thanked: 0

Re: Failing to boot after install

Post by jcpollman »

Partial success: I remember reading somewhere where Windows 10 should not be installed from a USB 3.0 stick. So, I tried installing FreeBSD from a 2.0 stick/port and it worked! Getting X to work is still a PIA, but at least it boots. I tried the same with Ghost, but no luck, same error as before.

NevilleGoddard
Developer
Posts: 505
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 12 times

Re: Failing to boot after install

Post by NevilleGoddard »

What's your graphics card?

jcpollman
Posts: 13
Joined: Sat Dec 07, 2019 11:17 am
Has thanked: 0
Been thanked: 0

Re: Failing to boot after install

Post by jcpollman »

rx580

jcpollman
Posts: 13
Joined: Sat Dec 07, 2019 11:17 am
Has thanked: 0
Been thanked: 0

Re: Failing to boot after install

Post by jcpollman »

I have now tried 19.09, 19.10, 20.01, 20.02, and development release. I have tried both usb and burning to a dvd (I forgot how slow dvds can be). I have tried installing to both drives. The install does create an EFI directory, but somehow the boot process does not find a bootable partition. Ghost does give me an X environment - just can not run it unless booting off of the install media. Freebsd gives me a bootable system, but X will not work. I have installed these so many times that I no longer need to type anything in - my keyboard does it automatically :-)

Unless there are other suggestions, I think I am going to give this a break for while
JC

jcpollman
Posts: 13
Joined: Sat Dec 07, 2019 11:17 am
Has thanked: 0
Been thanked: 0

Re: Failing to boot after install

Post by jcpollman »

I cobbled together a computer out of some old bits and pieces (i7-2600) and got Ghost installed, boots after the install, and the video is the right resolution. So, at least for now, I can play around with, and maybe get real serious, with Ghost!

JC

NevilleGoddard
Developer
Posts: 505
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 8 times
Been thanked: 12 times

Re: Failing to boot after install

Post by NevilleGoddard »

When you run the live medium and get to the desktop which option do you choose? Scfb, vesa, Radeon or amdgpu?

Post Reply