GBD 10.3 install fine first update xorg dead

Questions about the installation of FreeBSD
Post Reply
dirkme
Posts: 25
Joined: Fri Aug 18, 2017 9:46 pm
Has thanked: 0
Been thanked: 0

GBD 10.3 install fine first update xorg dead

Post by dirkme » Fri Aug 18, 2017 9:52 pm

Dear Ghost-BSD Friends,

using Linux for a very long time I thought I gave GBSD a shot and when I installed it on my old laptop, I was very impressed.

But... I started an update and after I rebooted there was no xorg no more.

I tried to start xstart etc. no dice.

Guys, that is Linux from the 90s and I so hoped for BSD to get usable and somewhat reliable.

How does such a destructive update get through in BSD? I am so disappointed.

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: GBD 10.3 install fine first update xorg dead

Post by NevilleGoddard » Sat Aug 19, 2017 1:15 am

Hi, and welcome to GhostBSD!

Sorry about the problems you are having.

I'm using GhostBSD 10.3 on my laptop and it's running fine so perhaps we can solve your problem. At the moment we are going through a transition period where we are switching to using our own repositories, not the FreeBSD repositories, so this may be the cause of your troubles. GhostBSD is in my experience very stable and reliable.
Since you have exprience with Linux you can solve your problem by changing your repository using this guide:

viewtopic.php?f=69&t=715

I you installed GhostBSD on a laptop, perhaps you could provide more information like which graphics card and which version you installed, (xfce or mate).

Or perhaps you might like to try a newer version (GhostBSD11.1) which is ALPHA, but runs very well and has the GhostBSD repositories already enabled.

Download from here:

http://www.ghostbsd.org/11.1-ALPHA1

dirkme
Posts: 25
Joined: Fri Aug 18, 2017 9:46 pm
Has thanked: 0
Been thanked: 0

Re: GBD 10.3 install fine first update xorg dead

Post by dirkme » Sat Aug 19, 2017 1:05 pm

Thanks for your reply NevilleGoddard , I might try the new version on my gaming laptop and the 10.3 version with your servers on the work laptop I try my OSes on.

I will come back and post my results, but that take a while before I get to it.

Thanks

dirkme
Posts: 25
Joined: Fri Aug 18, 2017 9:46 pm
Has thanked: 0
Been thanked: 0

Re: GBD 10.3 install fine first update xorg dead

Post by dirkme » Wed Aug 23, 2017 1:23 pm

NevilleGoddard wrote:Hi, and welcome to GhostBSD!

Sorry about the problems you are having.

I'm using GhostBSD 10.3 on my laptop and it's running fine so perhaps we can solve your problem. At the moment we are going through a transition period where we are switching to using our own repositories, not the FreeBSD repositories, so this may be the cause of your troubles. GhostBSD is in my experience very stable and reliable.
Since you have exprience with Linux you can solve your problem by changing your repository using this guide:

viewtopic.php?f=69&t=715

I you installed GhostBSD on a laptop, perhaps you could provide more information like which graphics card and which version you installed, (xfce or mate).

Or perhaps you might like to try a newer version (GhostBSD11.1) which is ALPHA, but runs very well and has the GhostBSD repositories already enabled.

Download from here:

http://www.ghostbsd.org/11.1-ALPHA1
Just an update: I had installed TrueOS afterwards and had the same issue after updating my XFCE was not showing up anymore.

That makes me think something funny is happening with that update.

However, I now installed GhostBSD 11.1 ALPHA and ran updates and all seems to work just fine. Looking forward to explore your Distro, you could become like the Antergos for Arch so GhostBSD could be for FreeNas ;-)

I have another laptop, where I have a few Linux distros running, just wondering, how would I add GhosBSD on a partition without destroying my already OSes on that HDD, in linux I know my way in and out, even BSD is similar, it is not the same.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: GBD 10.3 install fine first update xorg dead

Post by ASX » Mon Aug 28, 2017 1:26 pm

dirkme wrote: That makes me think something funny is happening with that update.
Yep, what is hapening is that Xorg was updated and somehow they changed some hardware detection, that worked previously but didn''t after the update.

For intel based cards the solution is relatively simple. just add "i915kms" to the KLD_LIST="..." variable and/or install "xf86-video-intel", after that Xorg should work again.

KC_386
Posts: 5
Joined: Wed Oct 04, 2017 7:03 pm
Has thanked: 0
Been thanked: 0

Re: GBD 10.3 install fine first update xorg dead

Post by KC_386 » Wed Oct 04, 2017 8:53 pm

I had the same problem after the first upgrade, according to Linux I have Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller.
So how do I do the "relatively simple. just add "i915kms" to the KLD_LIST="..." variable and/or install "xf86-video-intel", after that Xorg should work again."
It is not obvious to me dispite reading FreeBSD handbook many, many, many times.

ASX
Posts: 988
Joined: Wed May 06, 2015 12:46 pm
Has thanked: 0
Been thanked: 0

Re: GBD 10.3 install fine first update xorg dead

Post by ASX » Thu Oct 05, 2017 1:02 am

KC_386 wrote:I had the same problem after the first upgrade, according to Linux I have Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller.
So how do I do the "relatively simple. just add "i915kms" to the KLD_LIST="..." variable and/or install "xf86-video-intel", after that Xorg should work again."
It is not obvious to me dispite reading FreeBSD handbook many, many, many times.
KLD_LIST is a variable set in /etc/rc.conf, therefore you need to edit the file and include that like to look something like:

Code: Select all

kld_list="linux nvidia coretemp fuse i915kms"
xf86-video-intel is a package, you can install using: (from root or using sudo)

Code: Select all

pkg install xf86-video-intel
after that, reboot ;)

KC_386
Posts: 5
Joined: Wed Oct 04, 2017 7:03 pm
Has thanked: 0
Been thanked: 0

Re: GBD 10.3 install fine first update xorg dead

Post by KC_386 » Thu Oct 05, 2017 7:45 pm

@ ASX,

Thank you for the quick reply, I need to get hard disk reloaded with the OS first, so sometime after the weekend.

P.S. I assume editing is via 'easy editor' (ee) with a command

Code: Select all

ee /etc/rc.conf  
(I just found '...freebsd/how-to-guides/freebsd-set-up-tips/', and that's what it says.)

Much appreciated, keep-up the good work! :)

dirkme
Posts: 25
Joined: Fri Aug 18, 2017 9:46 pm
Has thanked: 0
Been thanked: 0

Re: GBD 10.3 install fine first update xorg dead

Post by dirkme » Sun Jan 28, 2018 4:20 pm

Thanks guys for all your input.

I have a little youtube channel and will post some of this Forum on it to how that if you use GhostBSD and have trouble, there is help available.

Dirk

dirkme
Posts: 25
Joined: Fri Aug 18, 2017 9:46 pm
Has thanked: 0
Been thanked: 0

Re: GBD 10.3 install fine first update xorg dead

Post by dirkme » Mon Jan 29, 2018 12:34 am

HPLIP-GUI installed right, solved printing and scanning works just fine


https://youtu.be/tdfNrvDaOrc

Post Reply