Page 1 of 1

PHP not working properly

Posted: Tue Jan 23, 2018 12:07 pm
by dhenzler
I've just found GhostBSD 11.1, and am pleased that someone finally integrated all of the setup BS into a DVD. Can't begin to express my frustration with FreeBSD and their lack of doing this.

On to my issue.... I have loaded Apache24 PHP56 and MySQL in order to do two things. NextCloud, and WordPress. However my PHP doesn't seem to be running properly.

I loaded PHP56 first, and then Apache24. When I didn't get any JOY on the php test screen, I loaded PHP70. Perhaps that was a mistake in install order. The PHP test screen came up, but PHP doesn't work with apps like WordPress or NextCloud. I also loaded phpMyAdmin which removed PHP7 and loaded PHP56. At any rate I am unable to run PHP code. Looked around, but the setup is different here than in Linux Mint. I have no idea what to do.

Anyone ?


Re: PHP not working properly

Posted: Tue Jan 23, 2018 5:41 pm
by Harion

I got similar trouble when I tried to install a phpBB forum. Screen went blank, nothing displayed.

First you need to see what the error is. Open /usr/local/etc/php.ini and set display_errors = On. I think you need to restart apache24 service (service apache24 restart). Then, try again and take note of the text displayed (you have to reverse this setting before to open your site to internet for security reasons).

For me, it was php56-tokenizer which wasn't installed. May be it's the same for you.

Re: PHP not working properly

Posted: Tue Jan 23, 2018 7:43 pm
by dhenzler
I got it working this afternoon. Just put it aside and let my brain rest. Found a good article on installing and configuring LAMP from ports binaries. ... eebsd-10-1 Since that is the way I do things, it worked out for me. Now I have different problems... The new release of Firefox doesn't want to run, and even balked at I dumped it for the time being and loaded Chromium. It will work until Firefox is fixed.

Now I get connecting to database problems that I didn't have initially. Because I cleaned up the MySQL database and set the root password. So will work on that next

Re: PHP not working properly  [SOLVED]

Posted: Wed Jan 24, 2018 12:13 pm
by dhenzler
Problem resolved after adding:
sudo vi /usr/local/etc/apache24/Includes/php.conf