Edit MATE menu?

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
Posts: 67
Joined: Mon Jul 10, 2017 9:50 pm
Has thanked: 5 times
Been thanked: 2 times

Edit MATE menu?

Post by frogprince »

I must apologize for another question; I'm still working my way through my new install.
I want to rearrange the entries in the MATE menu. If I click on System/Control Center/Main Menu,
I get the right window, but no changes that I make stick. So as root I type "mozo", and
get the same menu, as root. But still, none of my changes show up in the menu. Next I
tried the process described in:


but still, I cannot get any changes to show up in the actual menu. Is this a FreeBSD
problem that should be reported as a bug to them, or ???

Thanks again for your help!.. :P
Vas you efer in Zinzinnati? Asus F1A75-M, AMD A8-3870 APU, 6 GB DDR3/120 GB SSD, GeForce 210, missing front drive panel just like its owner.

Posts: 312
Joined: Sun Sep 04, 2016 12:30 pm
Has thanked: 0
Been thanked: 0

Re: Edit MATE menu?

Post by kraileth »

Oops, this has been quite long-standing without any answer... :( I probably missed it because it was in the wrong section of the forums, so I moved it here now.

About the problem: For me editing the menu works - not as I would have imagined, but at least at all. I've successfully disabled and re-enabled the "education" section. However the menu is not updated live. In fact I had to reboot (!) to make it notice the changes. This is certainly less than cool, but the functionality is there. I've installed 10.3 and tried out the same there to rule out that this is a regression with the MATE 1.18 update - but no, MATE 1.12 also shows this somewhat lazy behavior...
frogprince wrote:So as root I type "mozo", and get the same menu, as root. But still, none of my changes show up in the menu.
Do not run mozo as root! The menus should be configured per-user (~/.config/menus/) and changing the root user's menus is definitely not what you want.

Have you tried rebooting after making changes? For me that had the desired effect. No excessive testing was done on my part, though. It might well be that other changes than the simple thing I tested won't work at all and mozo is seriously broken.

Post Reply