System Crash During Updates, Now Software Won't Launch

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
chemikalguy
Posts: 13
Joined: Mon Mar 16, 2020 4:23 pm
Has thanked: 0
Been thanked: 0

System Crash During Updates, Now Software Won't Launch

Post by chemikalguy »

I got a notification that there was a software update, so I clicked it, and while it was running the system crashed and rebooted. I logged back in, thinking everything was ok, but found that I many applications won't launch, including the MATE Terminal, Firefox, Iridium, Software Update, Software Station, etc. I noticed that even the network icon doesn't show up in the top right corner of the screen like it used to.

Is there a way to save this system, or am I going to be stuck having to reinstall it from scratch again. This is my third attempt at getting a stable system going, and I thought I was on the right path. As a fairly new 'nix user, this is making me want to throw up my hands in frustration and give up. If anyone can offer guidance on repairing the damage, I would really appreciate it. For background, the system is running on VMWare 6.0, has 2 CPUs, 8GB of memory, and 60GB of hard disk space.

chemikalguy
Posts: 13
Joined: Mon Mar 16, 2020 4:23 pm
Has thanked: 0
Been thanked: 0

Re: System Crash During Updates, Now Software Won't Launch

Post by chemikalguy »

Ok, so I made a little progress.

Someone on another forum recommended that since it was in the middle of a package upgrade, that I should try running pkg upgrade -f from a root console (Ctrl-Alt-F2 instead of logging in as user) and rebooting. This should force a redownload and reinstallation of every package installed on your system.

So, I was able to figure out how to send the CTRL-ALT-F2 command and tried running the command to do the redownload and install. So, 858 packages downloaded and started extracting and installing, but it hung on package 65. This is what it said on 65/858: (keep in mind that I'm hand typing all this below, so any spelling mistakes are my own)

[ 65/858] Reinstalling dbus-1.12.20...

===> Creating groups

Using existing group 'messagebus'

===> Creating users

Using existing user 'messagebus'.

[ 65/858] Extracting dbus-1.12.20: 100%

*Performing sanity check on apache24 configuration:

AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using ::1. Set the 'ServerName' directive globally to suppress this message

Syntax OK

*Performing a graceful restart

AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using ::1. Set the 'ServerName' directive globally to suppress this message

httpd not running, trying to start

*WARNING: you are stopping a boot service


After that, nothing. It's been sitting at this stage for an hour. Not sure what to do from here.

chemikalguy
Posts: 13
Joined: Mon Mar 16, 2020 4:23 pm
Has thanked: 0
Been thanked: 0

Re: System Crash During Updates, Now Software Won't Launch

Post by chemikalguy »

I finally decided to CTRL-C on the upgrade and run it again. This time, I got a process with PID xxxx holds the lock. I killed that process and restarted the upgrade. This time, it completed successfully. I rebooted and all appears to be well.

Post Reply