Softerther installation fails with conflicting libraries..

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
freddell
Posts: 2
Joined: Mon Apr 20, 2020 5:54 am
Has thanked: 0
Been thanked: 0

Softerther installation fails with conflicting libraries..

Post by freddell »

Hi I get the below conflict when installing softether:
"pkg: os-nozfs-userland-lib32-12.1.20200131232158 conflicts with os-generic-userland-lib32-12.1.20200314002211 (installs files into the same place). Problematic file: /usr/lib32/i18n/libmapper_parallel.so.4"

Output:
New packages to be INSTALLED:
blas: 3.5.0_6 [GhostBSD]
gnatcross-sysroot-aarch64: 1_1 [GhostBSD]
lapack: 3.5.0_8 [GhostBSD]
os-minimal-userland-lib: 12.1.20200131232158 [GhostBSD_PKG]
os-minimal-userland-lib32: 12.1.20200131232158 [GhostBSD_PKG]
os-nozfs-userland-lib: 12.1.20200131232158 [GhostBSD_PKG]
os-nozfs-userland-lib32: 12.1.20200131232158 [GhostBSD_PKG]
softether: 4.29.9680_4 [GhostBSD_PKG]

Number of packages to be installed: 8

The process will require 319 MiB more space.
28 MiB to be downloaded.

Proceed with this action? [y/N]: y
[1/4] Fetching os-nozfs-userland-lib32-12.1.20200131232158.txz: 100% 7 MiB 427.4kB/s 00:16
[2/4] Fetching os-nozfs-userland-lib-12.1.20200131232158.txz: 100% 7 MiB 599.5kB/s 00:12
[3/4] Fetching os-minimal-userland-lib32-12.1.20200131232158.txz: 100% 7 MiB 541.9kB/s 00:14
[4/4] Fetching os-minimal-userland-lib-12.1.20200131232158.txz: 100% 8 MiB 346.6kB/s 00:23
[1/8] Installing blas-3.5.0_6...
[1/8] Extracting blas-3.5.0_6: 100%
* WARNING: you are stopping a boot service
[2/8] Installing softether-4.29.9680_4...
[2/8] Extracting softether-4.29.9680_4: 100%
[3/8] Installing gnatcross-sysroot-aarch64-1_1...
[3/8] Extracting gnatcross-sysroot-aarch64-1_1: 100%
[4/8] Installing os-nozfs-userland-lib32-12.1.20200131232158...
pkg: os-nozfs-userland-lib32-12.1.20200131232158 conflicts with os-generic-userland-lib32-12.1.20200314002211 (installs files into the same place). Problematic file: /usr/lib32/i18n/libmapper_parallel.so.4

User avatar
ericbsd
Developer
Posts: 1526
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 47 times
Been thanked: 78 times

Re: Softerther installation fails with conflicting libraries..

Post by ericbsd »

Remove /usr/local/etc/pkg/repos/GhostBSD.conf

Post Reply