Linker error while using 'Rust'

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
NeverSimple
Posts: 39
Joined: Sun Aug 20, 2017 10:08 am
Has thanked: 1 time
Been thanked: 0

Linker error while using 'Rust'

Post by NeverSimple » Sun Nov 17, 2019 9:51 am

Using GhostBSD19.09 upgraded to 19.10.

I Installed Rust (programming language) to compile some code.
Cargo gives me 'linker 'cc' not found' while doing that.

'which cc' gives me nothing.
Not even sure if CLANG is installed. It is not available as a package, GCC is.

But this is a bit out of my comfort zone, so before creating a ginormous mess, Ill ask here what is the best way to solve this.

User avatar
ericbsd
Developer
Posts: 1438
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 39 times
Been thanked: 53 times

Re: Linker error while using 'Rust'

Post by ericbsd » Mon Nov 18, 2019 1:58 pm

devtools is not installed by default you have to installed it.

Code: Select all

sudo  pkg install os-generic-userland-devtools
These users thanked the author ericbsd for the post:
NeverSimple (Mon Nov 18, 2019 2:22 pm)
Rating: 50%

Post Reply