19.09 : Issues with my AMD card

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
dismas
Posts: 9
Joined: Mon Jan 14, 2019 9:17 am
Has thanked: 0
Been thanked: 0

19.09 : Issues with my AMD card

Post by dismas » Sat Sep 21, 2019 6:11 am

Hello,
I'm having an issue with my graphic card and 19.09. It is an AMD Radeon HD 5750.
- In the live session, mouse is working but I have no pointer. I changed it and its size but in vain.
- If I choose "amd" or "startx" in the X Configuration Menu, my computer does not (or does not seem to) boot after the installation. Monitor goes to sleep.
- If I choose "vesa" in the X Configuration Menu, my computer boots after installation and the pointer is back.
If was working OK with 19.04. Is there something I can tried to make it work like before ? I'm no expert in X configuration and don't know how to load another driver to test it.
Thanks.
:arrow: Sorry for my bad English : I'm French

dismas
Posts: 9
Joined: Mon Jan 14, 2019 9:17 am
Has thanked: 0
Been thanked: 0

Re: 19.09 : Issues with my AMD card

Post by dismas » Tue Oct 08, 2019 3:05 am

Hello,
I eventually got it working after installing GhostBSD using the VESA driver and the drm-legacy-kmod package. I thought it was time to buy a new graphic card : Nvidia GeForce 1030 works like a charm.
Nothing to do with the above but :
  • The dots appearing in LightDM are not artefacts but come from the draw-grid parameter sets to true in /usr/local/etc/lightdm/slick-greeter.conf. Simply set it to false to make them disappear.
  • I don't know why but the firefox package is shown as not installed in Software Station. If you prefer the ESR version like me, you have to go with pkg delete firefox to uninstall it first.
Regards.
Attachments
Capture3.PNG
Capture3.PNG (8.32 KiB) Viewed 100 times
:arrow: Sorry for my bad English : I'm French

Post Reply