No sound control on GhostBSD 19.09 MATE

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
NeverSimple
Posts: 36
Joined: Sun Aug 20, 2017 10:08 am
Has thanked: 0
Been thanked: 0

No sound control on GhostBSD 19.09 MATE

Post by NeverSimple » Mon Sep 16, 2019 7:54 pm

On my fresh install off GhostBSD 19.09 MATE, I can't seem to control the volume, the speaker icon in the panel is grayed out, the dropdown from it is a plain white field.
If I use the hardware buttons on the laptop (Fn+F6/F7) the volume control works correct.
On 'Control center' > 'Sound', 'Sound preferences', 'Hardware' tab, there is no device present.
If I use the volume slider on that, it also works, although it looks really 'greyed out'

If I look at 'dmesg' it detects
hdac0: <Intel Haswell HDA Controller> mem xxx at device 3.0 on pci0
hdac1: <Intel Lynx Point-LP HDA Controller> mem xxx at device 27.0 on pci0
It also detects subsystems: hdacc0, hdaa0, pcm0, hdacc1, hdaa1, pcm1, pcm2

But 'dmesg' is filled with a couple of hundred lines:
hdac0: Unexpected unsolicited response from address 0: 00000000
followed by a couple of dozen:
hdac0: command timeout on address 0

I've attached the text from dmesg. Any idea's how to solve this?

NOTE: the first couple of times I logged into the system, the panel would be completely empty, no icons or any way to access applications. The icons were there on the login screen, but vanished after login. I reset the panel (right click > Reset panel) and after that it looked and worked fine, but no volume control. Don't know if these two things are related.
Attachments
dmesg.zip
(4.51 KiB) Downloaded 2 times

User avatar
ericbsd
Developer
Posts: 1398
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 37 times
Been thanked: 46 times

Re: No sound control on GhostBSD 19.09 MATE

Post by ericbsd » Tue Sep 17, 2019 5:22 pm

I have the same problem with my Lenovo X1 Carbon, and so far it is the only hardware I have that has done this and I also have the problem with the volume control. So you are probably on to something with this, thanks for sharing moving to pulse audio have solved problems but cause other problem.

Post Reply