Some problems i found with ghostbsd

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
chrisfromgreece
Posts: 23
Joined: Mon Feb 19, 2018 11:19 am
Has thanked: 1 time
Been thanked: 0

Some problems i found with ghostbsd

Post by chrisfromgreece » Sun Mar 24, 2019 4:37 pm

1) Pulseaudio Applet doesn't change the volume of my soundcard but a hdmi output i don't use, i don't have even hdmi i use displayport
2) Pulseaudio can't select default soundcard
3) Kaffeine needs some qt packages to be installed in order to start please update the dependencies if you can,
also kaffeine failed to detect my dvb-t usb tv which i have no problem using on freebsd
4) Searching on octopkg is slow when i enter the search terms it freezes for some time
5) Big problems installing on an TEAM L7 EVO SSD sata disk installation failure, corrupt partitions that can't boot at all after two or three reboots completely disaster !!! I tested with zfs and ufs everything has problems !!!! I have reported this problem again i think
6) Can't install chromium
7) Tried to install hplip from package manager can't add my printer it says missing ppds then when i select the corresponded ppd it doesn't do anything can't select it can't go forward , then i tried to install it from the ports same ! maybe it is not good to install this package from pkg at all
8) cant change volume , the system can't detect when i press the media/volume keys at all

User avatar
ericbsd
Developer
Posts: 1355
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 34 times
Been thanked: 39 times

Re: Some problems i found with ghostbsd

Post by ericbsd » Mon Mar 25, 2019 4:47 pm

chrisfromgreece wrote:
Sun Mar 24, 2019 4:37 pm
1) Pulseaudio Applet doesn't change the volume of my soundcard but a hdmi output i don't use, i don't have even hdmi i use displayport
2) Pulseaudio can't select default soundcard
That would be FreeBSD ports related issue and not GhostBSD even and I am the ports maintainer. It is a known issue but it the only 24 hours in a day it is a low priority.
chrisfromgreece wrote:
Sun Mar 24, 2019 4:37 pm
3) Kaffeine needs some qt packages to be installed in order to start please update the dependencies if you can,
also kaffeine failed to detect my dvb-t usb tv which i have no problem using on freebsd
6) Can't install chromium
On the 18 release, there will be no more update, 19.03 is almost ready and there is RC in the latest repository with packages up to date and it is more a bit stable than 18.
chrisfromgreece wrote:
Sun Mar 24, 2019 4:37 pm
4) Searching on octopkg is slow when i enter the search terms it freezes for some time
That will need to be reported to the port maintainer, GhostBSD is not maintaining octopkg, we did also replace by our in house pkg manager, software-station.
chrisfromgreece wrote:
Sun Mar 24, 2019 4:37 pm
5) Big problems installing on a TEAM L7 EVO SSD sata disk installation failure, corrupt partitions that can't boot at all after two or three reboots completely disaster !!! I tested with zfs and ufs everything has problems !!!! I have reported this problem again I think
]
I only have AData and WD SSD and never had a problem with them, I can't see TEAM L7 EVO SSD be the source of the problem since I do not own the hardware there is not much I can do to figure the problem.
chrisfromgreece wrote:
Sun Mar 24, 2019 4:37 pm
7) Tried to install hplip from package manager can't add my printer it says missing ppds then when i select the corresponded ppd it doesn't do anything can't select it can't go forward, then i tried to install it from the ports same ! maybe it is not good to install this package from pkg at all
I think you could have more help on Telegram for that since there are people that had similar issues.
chrisfromgreece wrote:
Sun Mar 24, 2019 4:37 pm
8) cant change volume , the system can't detect when i press the media/volume keys at all
I think it is normal since we did not implement anything to ensure all media/volume keys work out of the box. it is working on some laptop, but not on most keyboards.

NevilleGoddard
Developer
Posts: 475
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 9 times
Been thanked: 10 times

Re: Some problems i found with ghostbsd

Post by NevilleGoddard » Sat Mar 30, 2019 1:17 am

Chrisfromgreece about the hplip problem, it may help to delete the foomati-db-engine package

pkg delete foomati-db-engine

Then try again.

NevilleGoddard
Developer
Posts: 475
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 9 times
Been thanked: 10 times

Re: Some problems i found with ghostbsd

Post by NevilleGoddard » Sat Mar 30, 2019 1:17 am

Thanks for the feedback by the way

chrisfromgreece
Posts: 23
Joined: Mon Feb 19, 2018 11:19 am
Has thanked: 1 time
Been thanked: 0

Re: Some problems i found with ghostbsd

Post by chrisfromgreece » Sat Mar 30, 2019 6:45 am

I tried the development version it was by far cooler every problem was solved i used zfs for partitioning.
I wanted to make it my daily driver but using an nvidia on video applications on freebsd is something that can't be done because every single application has problem working with nvidia drivers, from shotcut ,kdenlive to old cinellera none worked crashed before i could even import a file maybe its the hardware acceleration that is incompatible with nvidia maybe is missing codecs i dont know .
And bsd has problems working with my amd r7 intergrated gpu its not working on ghostbsd , on linux it uses by default the opensource amdgpu driver which is very good and capable especially on shotcut i can preview on the fly layers of videos and processing demanding effects without any problems and with smooth fps .(something that my friend with the i7 and nvidia 1060 simply can't do at all on adobe premier/after effects he has freaking 1fps preview playback without any effects at all) This is the best example of the power of free software and open source.

--I must admit that on ghostbsd everything seems to be a bit more fast compared to linux feels more snappier .
The problem is i really need to use these video editors .....
Last edited by chrisfromgreece on Sun Mar 31, 2019 8:17 am, edited 2 times in total.

NevilleGoddard
Developer
Posts: 475
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 9 times
Been thanked: 10 times

Re: Some problems i found with ghostbsd

Post by NevilleGoddard » Sat Mar 30, 2019 8:46 am

Strange. Nvidia works fine for me on GhostBSD.
I'm using an R9-270 and it also works fine using the amdgpu driver.
Maybe yours isn't configured properly. Try this:

pkg ins drm-current-kmod

ee /etc/rc.conf

Put in rc.conf

kld_list="/boot/modules/radeonkms.ko"

And reboot

See if this helps

chrisfromgreece
Posts: 23
Joined: Mon Feb 19, 2018 11:19 am
Has thanked: 1 time
Been thanked: 0

Re: Some problems i found with ghostbsd

Post by chrisfromgreece » Sun Mar 31, 2019 8:24 am

Nvidia works on ghostbsd video editing software doesn't !
I believe because they are depending on freir hardware acceleration i don't know for sure maybe its the codecs? i don't know they simply don't work !
I'm using the intergrated amd r7 right now cause it has the best performance on these software plus i can use hardware acceleration on obs-studio when i want to broadcast.

the radeonkms is the old version of amd drivers ? radeon used to be better than fglrx for gaming but amdgpu is by far the best.

I haven't tried the new testing/dev isos with the r7 , only with the nvidia.
A very good work done in the new release if i found a solution with my graphics card i will make it my daily driver
i have turned to freebsd/ghostbsd because i like to be restricted on open source/free software and not tempted by proprietary software and games ,
games is bad for my productivity very bad.

I tried two times to configure freebsd the first was succesful the next even everything worked i had a problem with the locale , my keyboard could not insert Tones ' above letters , i'm from greece and i need this, i didn't found a solution for that.

On ghostbsd everything works fine.
NevilleGoddard wrote:
Sat Mar 30, 2019 8:46 am
Strange. Nvidia works fine for me on GhostBSD.
I'm using an R9-270 and it also works fine using the amdgpu driver.
Maybe yours isn't configured properly. Try this:

pkg ins drm-current-kmod

ee /etc/rc.conf

Put in rc.conf

kld_list="/boot/modules/radeonkms.ko"

And reboot

See if this helps

chrisfromgreece
Posts: 23
Joined: Mon Feb 19, 2018 11:19 am
Has thanked: 1 time
Been thanked: 0

Re: Some problems i found with ghostbsd

Post by chrisfromgreece » Tue Apr 02, 2019 2:31 pm

Also i found another problem i forgot to report !
While on freebsd i have no problem configuring my amd r7 with the open source amdgpu driver ghostbsd just uses the slow old radeon driver i can't even move the windows !
Please configure amdgpu correctly is not that hard ! a kld_load amdgpu installation of drm-kmod and xorg installation with xorg-drivers
I would like to fix this issue with amd graphics cards driver.

Post Reply