Update Station issues

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
epsheldoni
Posts: 3
Joined: Wed Jan 23, 2019 1:58 pm
Has thanked: 0
Been thanked: 0

Update Station issues

Post by epsheldoni » Wed Jan 23, 2019 2:03 pm

I have completed the update, as far as I know, and I keep getting notifications "Update available". Where is there a log file that gives me information as to the status of the update or if there are any errors that need to be fixed? Thanks for the great work.

User avatar
ericbsd
Developer
Posts: 1368
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 36 times
Been thanked: 44 times

Re: Update Station issues

Post by ericbsd » Wed Jan 23, 2019 2:39 pm

You might have a pkg that does not get updated properly.

Do you have Gimp installed?

Doing sudo pkg upgrade you will see where it is failing.

epsheldoni
Posts: 3
Joined: Wed Jan 23, 2019 1:58 pm
Has thanked: 0
Been thanked: 0

Re: Update Station issues

Post by epsheldoni » Wed Jan 23, 2019 6:58 pm

Eric,
Thanks for the prompt reply. Yes, I do have GIMP installed.
When I do #sudo pkg upgrade, at the end of the readout I get the following.

Number of packages to be installed: 17
Number of packages to be upgraded: 560
Number of packages to be reinstalled: 37

The process will require 362 MiB more space.

Proceed with this action? [y/N]: y
[1/614] Installing py36-qt5-core-5.11.3_1...
pkg: py36-qt5-core-5.11.3_1 conflicts with py27-qt5-core-5.10.1 (installs files into the same place). Problematic file: /usr/local/bin/pyuic5

Do I delete the "problematic file"? Do I have to deinstall GIMP?

Thanks

User avatar
ericbsd
Developer
Posts: 1368
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 36 times
Been thanked: 44 times

Re: Update Station issues

Post by ericbsd » Thu Jan 24, 2019 8:52 am

Yeah delete py27-qt5-core-5.10.1, I know that GIMP is always a problem to update, but the last update did not GIMP on my development systems.

epsheldoni
Posts: 3
Joined: Wed Jan 23, 2019 1:58 pm
Has thanked: 0
Been thanked: 0

Re: Update Station issues

Post by epsheldoni » Thu Jan 24, 2019 12:28 pm

Eric,

I went into software station and could not find py27-qt5-core-5.10.1. I did see that py27-qt5-core-5.11.3_1 was not installed. I checked the box and clicked apply thereby installing it. Then I did "sudo pkg update" and everything installed. Thank you for your hard work on a great system.

User avatar
ericbsd
Developer
Posts: 1368
Joined: Mon Nov 19, 2012 7:54 pm
Has thanked: 36 times
Been thanked: 44 times

Re: Update Station issues

Post by ericbsd » Thu Jan 24, 2019 1:56 pm

since it fresh in my mind remove dhcpcd it is conflicting with the dhcpcd in the base and cause some problems with resolv.conf.

Post Reply