Page 1 of 2

(Solved!) Now the SSD is Borked

Posted: Mon Sep 17, 2018 6:23 pm
by frogprince
So..after borking a new HD, I installed Ghost on a new SSD. Now that's borked. I can boot to the login screen on MATE, but when I proceed to open the desktop, I get the desktop background with a one inch black line on the top that shows what looks like multiple small pages of text.
Eventually, the system reboots itself and does it again..and again. I ran fsck -y from Ghost on a USB drive, and it promptly said that the disk was fine. The file system is UFS. What the bleep?....I like Ghost, but I can't afford to keep buying new hard drives to keep it running.

Re: Now the SSD is Borked

Posted: Tue Sep 18, 2018 2:44 pm
by ericbsd
what you mean by borking and borked?

What version of GhostBSD and why not trying ZFS?

GhostBSD will put less and less effort on UFS.

Re: Now the SSD is Borked

Posted: Wed Sep 19, 2018 3:35 pm
by frogprince
Eric: thanks for your response. By "borked", I mean that I can no longer install Ghost on this SSD. When I initially put up the post, Ghost ignored my newer boot background, reverted to the original one on the iso, and kept flickering. Eventually, it self corrected to the point of booting to the MATE login screen, but as noted above, would not complete loading MATE, and simply rebooted after I entered my password. When attempting to reinstall Ghost, the process got to the point of installing


and then I once again got the one inch black stripe at the top of the screen with what looked like multiple text pages, and the system would reboot.
So to test the SSD, I reformatted it to FAT32 with gparted on a Puppy Linux USB drive that I use for such purposes, and then successfully installed Puppy on the drive; it booted and ran fine. So I redownloaded Ghost 11.1, burned it to a new DVD, and tried to reinstall again. And once again, it got to a certain point in the install, and then rebooted. When I attempted to boot the system from what had been installed, I get an immediate error after the BIOS screen:

gptzfs boot: error 4

The boot proceeds, but halts at

Loader variables:

Manual root filesystem specification:
<fstype>:<specifications> [options]
Mount <device> using file system <fstype>
and with the specified (optional) option list
eg. ufs:/dev/da0s1a
cd9660:/dev/cd0 ro
(which is equivalent to mount -t cd9660 -o ro /dev/cd0 /)
? list valid boot disk devices
. yield 1 second for background tasks
<empty line> abort manual input

Clearly, the install process did not complete to the point of installing the FreeBSD loader. I don't know what else is missing.
What I do know is that I installed Ghost BSD on this drive at least four times trying to get it to work, and finally succeeded and ran
it successfully for about a month. Then this happened, and I cannot reinstall.

When it works, I really like Ghost. It's very fast, uses the MATE desktop which I like, has the software that I look for, and is relatively
immune to the nasty stuff that is generally around the net. I like it better than TrueOS, which I've also tried. But between the two of them,
I'm now in possession of two mechanical HD's and two SSD's that I cannot install either OS on to. Is this a FreeBSD problem, or ???

Re: Now the SSD is Borked

Posted: Thu Sep 20, 2018 10:30 am
by ericbsd
that is really odd I have made a new iso Yesterday ... -15-18.iso it is base on TrueOS. Maybe that would work, but it is not normal that GhostBSD does that.

Re: Now the SSD is Borked

Posted: Mon Sep 24, 2018 5:30 pm
by jmp20
There could be leftover data on the MBR or EFI from previous GhostBSD installs. I would dd the first 100MB of the disk with something in the like of:

Code: Select all

dd if=/dev/zero of=/dev/ada0 count=100M
I had a similar problem with a computer, in that I did not re-format my root FS and simply let the installer do it. It then failed to boot after the install with very similar errors. I noticed that your install worked for about a month; I then wonder if there were any change to the boot directory, MBR, etc. at some point and created this problem?

Re: Now the SSD is Borked

Posted: Wed Sep 26, 2018 11:10 am
by frogprince
Okay. This problem isn't showing up elsewhere (thanks, Eric, for that insight, it's key) and the system ran well for a while. That sounds like hardware, chip set? i installed an Intel DH55TC i5 mother board (which I found has its own problems, won't auto boot from an SSD, which is one known problem, and
won't boot from a USB, which isn't), but Ghost installed from a DVD and seems to update and run fine if I hit F10 and select the right drive. I'm using the legacy BIOS mode, maybe UEFI would work, although that's the opposite of what the Intel forums say. I still have the bad? mechanical drives, so I may try using them instead of the SSD's and will report back as to the results.

Re: Now the SSD is Borked

Posted: Thu Sep 27, 2018 9:05 am
by ericbsd
The latest build base on TrueOS works better on UEFI.

Re: Now the SSD is Borked

Posted: Thu Sep 27, 2018 10:20 am
by ericbsd
@frogprince were you using Custom partition editor of the installer?

Re: Now the SSD is Borked

Posted: Thu Sep 27, 2018 10:22 am
by ericbsd
I have discovered that the custom partition editor does not clear the drive properly.

Re: Now the SSD is Borked

Posted: Fri Sep 28, 2018 7:28 pm
by frogprince
Hmm..Eric, I don't remember if I used custom or standard. The machine has two HD's, so I had to pick one; did I need Custom to do that?