How to boot GhostBSD from a GRUB 2 config?

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
rowo
Posts: 12
Joined: Thu Jul 12, 2018 10:35 am
Has thanked: 1 time
Been thanked: 2 times

How to boot GhostBSD from a GRUB 2 config?

Post by rowo » Thu Jul 12, 2018 10:59 am

I installed GhostBSD from GhostBSD11.1-xfce-amd64.iso into the 3rd partition (DOS PT) of my second HDD, that is /dev/sdb3 for Linux and /dev/ada1s3 for BSD. I tried various different entries for grub.cfg (using openSUSE Tumbleweed) but none of them works.

The first three entries result in an error message "invalid signature", the last two ones in
"unknown file system
you must load the kernel first"

I am sure to use the correct partition because I can easily mount it under Linux:
mount -r -t ufs -o ufstype=ufs2 /dev/sdb3 /mnt

So what is the correct entry for grub.cfg?

Content for GhostBSD in grub.cfg:

Code: Select all

menuentry "GhostBSD 11.1 @ (hd1,3)" {
   set root=(hd1,msdos3)
   chainloader +1
}
menuentry "GhostBSD 11.1 @ (hd1,3)" {
   set root=(hd1,3)
   chainloader +1
}
menuentry "GhostBSD 11.1 @ (hd1,3)" {
   insmod ufs2
   insmod bsd
   set root=(hd1,3)
   chainloader +1
}
menuentry "GhostBSD 11.1 @ (hd1,3)" {
   insmod ufs2
   insmod bsd
   set root=(hd1,3)
   kfreebsd /boot/loader
   kfreebsd_loadenv /boot/device.hints
   set kFreeBSD.vfs.root.mountfrom=ufs:/dev/ada1s3a
   set kFreeBSD.vfs.root.mountfrom.options=rw
}

menuentry "GhostBSD 11.2 @ (hd1,3)" {
   insmod ufs2
   insmod bsd
   set root=(hd1,3)
   kfreebsd /boot/kernel/kernel
   kfreebsd_loadenv /boot/device.hints
   set kFreeBSD.vfs.root.mountfrom=ufs:/dev/ada1s3a
   set kFreeBSD.vfs.root.mountfrom.options=rw
}

User avatar
Powerwagon77
Posts: 18
Joined: Sat Jul 07, 2018 2:14 pm
Has thanked: 3 times
Been thanked: 4 times

Re: How to boot GhostBSD from a GRUB 2 config?

Post by Powerwagon77 » Fri Jul 27, 2018 11:31 pm

I'm dual booting from Fedora, though I'm booting less and less from it. Here is my grub2 entry:

menuentry "GhostBSD" {
set root='hd0,msdos1'
kfreebsd /boot/loader
}

You should be able to modify my second line to hd1,msdos3 and be good to go.

Post Reply