CUPS error-Fixed by Going from XFCE to MATE

Need support for GhostBSD. Ask here if your question does not fit elsewhere.
Post Reply
frogprince
Posts: 40
Joined: Mon Jul 10, 2017 9:50 pm
Has thanked: 0
Been thanked: 0

CUPS error-Fixed by Going from XFCE to MATE

Post by frogprince » Sun Feb 25, 2018 10:48 pm

I decided to look at XFCE on Ghost, and reinstalled with that desktop. However, I cannot get CUPS to work. I installed my HP 2420DN LAN printer using the Gutenprint driver as before, but it will not print a test page. The dialog box for "Printers" no longer shows the printer that I installed, so I can't delete it to try a different driver and I get an error message:

Failed to contact configuration server; the most common cause is a missing or misconfigured D-Bus session bus daemon. See http://projects.gnome.org/gconf/ for information.

Trying to access the printer through Firefox/localhost:631, I click on Administration, and find the printer. However, clicking on that printer leads me to the screen listing the details for that printer, but the Administration and Maintenance windows show up blank when i click on them. HPLIP is installed, and using that package to access the printer does not work either. Reinstalling all the CUPS packages changes nothing. Do we have a bug?

Thanks in advance for your help.
Last edited by frogprince on Wed Mar 07, 2018 11:05 pm, edited 1 time in total.
Vas you efer in Zinzinnati? Asus M2N-MX, Athlon 64 3800+ CPU, 4 GB/250 GB, GeForce 210, missing front drive panel just like its owner.

frogprince
Posts: 40
Joined: Mon Jul 10, 2017 9:50 pm
Has thanked: 0
Been thanked: 0

Re: CUPS error-Workaround

Post by frogprince » Wed Mar 07, 2018 11:04 pm

In frustration and receiving no responses on this issue, I reinstalled Ghost 11.1, but went back to MATE. After the install, I installed all the updates generated by Octopkg, but still had the CUPS error. Then, Update Station popped up with a notification for an update labelled "11.1 Release p6". Afterward, CUPS ran fine and let me install my LAN printer with no errors. This looks like a FreeBSD problem that got corrected, but I'm not going back to XFCE to see if it's available for that desktop when this one runs so well.
Vas you efer in Zinzinnati? Asus M2N-MX, Athlon 64 3800+ CPU, 4 GB/250 GB, GeForce 210, missing front drive panel just like its owner.

NevilleGoddard
Developer
Posts: 399
Joined: Thu Dec 22, 2016 10:30 pm
Location: Japan
Has thanked: 4 times
Been thanked: 2 times

Re: CUPS error-Fixed by Going from XFCE to MATE

Post by NevilleGoddard » Sat Mar 10, 2018 8:15 pm

Just curious, but why use the gutenprint driver?
Doesn't it work with the hplip package?

Post Reply